Bug 428613 - vmware_drv.so fails to load on missing PictureScreenPrivateIndex symbol
vmware_drv.so fails to load on missing PictureScreenPrivateIndex symbol
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-vmware (Show other bugs)
rawhide
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 01:45 EST by Gilboa Davara
Modified: 2008-01-24 05:56 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 13:09:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (824 bytes, text/plain)
2008-01-14 10:54 EST, Gilboa Davara
no flags Details
Xorg log file. (5.58 KB, text/plain)
2008-01-14 10:56 EST, Gilboa Davara
no flags Details
pciaccess fix (23.62 KB, patch)
2008-01-16 09:53 EST, Denis Leroy
no flags Details | Diff

  None (edit)
Description Gilboa Davara 2008-01-14 01:45:41 EST
Fully updated rawhide / x86_64.
X no longer loads.

Error:
$ cat /var/log/Xorg.0.log | grep vmware
(II) LoadModule: "vmware"
(II) Loading /usr/lib64/xorg/modules/drivers//vmware_drv.so
dlopen: /usr/lib64/xorg/modules/drivers//vmware_drv.so: undefined symbol:
PictureScreenPrivateIndex
(EE) Failed to load /usr/lib64/xorg/modules/drivers//vmware_drv.so
(II) UnloadModule: "vmware"
(EE) Failed to load module "vmware" (loader failed, 7)
$ rpm -qa | grep vmware
xorg-x11-drv-vmware-10.15.2-1.fc8.x86_64

- Gilboa
Comment 1 Matěj Cepl 2008-01-14 08:28:53 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

There has to be something wrong with you installation. When I try

rpm -ql xorg-x11-drv-vmware-10.15.2-1.fc8.x86_64

I get (among other things)

/usr/lib64/xorg/modules/drivers/vmware_drv.so

Could you try to run (as root)

yum clean all
yum upgrade

and then to send us the output of the above shown rpm command, please?

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Gilboa Davara 2008-01-14 10:54:16 EST
Created attachment 291598 [details]
xorg.conf
Comment 3 Gilboa Davara 2008-01-14 10:56:39 EST
Created attachment 291599 [details]
Xorg log file.
Comment 4 Gilboa Davara 2008-01-14 11:01:28 EST
I should clerify the vmware_drv does exists (and get detected just fine) - it's
just missing a symbol. (PictureScreenPrivateIndex)

Never the less:
$ rpm -qf /usr/lib64/xorg/modules/drivers/vmware_drv.so
xorg-x11-drv-vmware-10.15.2-1.fc8.x86_64

P.S. I'm getting the same error from the KDE4 LiveCD.

- Gilboa
Comment 5 Denis Leroy 2008-01-16 09:53:27 EST
Created attachment 291856 [details]
pciaccess fix

Rebuilding the package with the attached patch (from upstream) works for me.
Comment 6 Adam Jackson 2008-01-22 13:09:22 EST
Fixed in rawhide, thanks!
Comment 7 Gilboa Davara 2008-01-24 05:56:37 EST
Seems to work just fine.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.