Bug 428697 - No connection between wlan card and router with module rt61pci
No connection between wlan card and router with module rt61pci
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 12:26 EST by Mats Ljunggren
Modified: 2009-01-09 02:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:55:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mats Ljunggren 2008-01-14 12:26:58 EST
Description of problem:
My wlan card (RaLink RT2561/RT61 rev B 802.11g) with module rt61pci doesn't 
associate any longer with my wlan router. iwlist wlan0 scan doesn’t show any 
access points. I tested both kernel-2.6.23.13-104.fc8 and kernel-2.6.23.13-
105.fc8 with the same result.

Version-Release number of selected component (if applicable):
kernel-2.6.23.13-104.fc8
kernel-2.6.23.13-105.fc8

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
No connection between wlan card and router

Expected results:
A connection

Additional info:
dmesg output:
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:0f:66:c7:a4:ef
wlan0: RX authentication from 00:0f:66:c7:a4:ef (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:0f:66:c7:a4:ef
wlan0: associate with AP 00:0f:66:c7:a4:ef
wlan0: associate with AP 00:0f:66:c7:a4:ef
wlan0: association with AP 00:0f:66:c7:a4:ef timed out
Comment 1 Chuck Ebbert 2008-01-22 19:40:27 EST
2.6.23.14-115 is in testing now, please test that and report back.
Comment 2 Mats Ljunggren 2008-01-24 15:00:09 EST
I have no problem with network connection any longer with this kernel. I have 
run it for more than one day. Bit rate vs. link quality regulation works much 
better than before too.
Comment 3 Clive Malcolm 2008-01-25 04:00:02 EST
Hi,

I have an Edimax EW-7108PCG card which uses the rt61pci driver.

I install updates as they are suggested by the update utility, this morning I
said yes to kernel 2.6.23.14-107 and then my wireless card would not connect my
to router :(

Some help via IRC suggested I file a bug via bugzilla, searching for rt61pci I
found this article but no instructions for a fix.

help via IRC suggested these commands, which worked for me.

http://koji.fedoraproject.org/koji/buildinfo?buildID=32352 download correct package.

sudo yum localinstall --nogpgcheck kernel-2.6.23.14-115.fc8.i686.rpm

Rebooted with 2.6.23.14-115 and I can connect again.

some info.

lspci
===
02:00.0 Network controller: RaLink RT2561/RT61 802.11g PCI

and I am on a 32 bit os not x86_64

one, final thing, for me the kernel update did not "just work" and I had to boot
into a previous kernel and manually download a fix, not sure what severity that
 would raise this bug to, but lots of people with rt61pci drivers will have a
broken system today.

Thanks to everyone for fixing this bug.
Comment 4 Patrick Sefton 2008-01-25 18:17:50 EST
Same problem here (and same solution)

# lspci | grep Network
06:0d.0 Network controller: RaLink RT2561/RT61 rev B 802.11g

- previously running 2.6.23.9-85.fc8
- updated to kernel 2.6.23.14-107.fc8 (prompted by software updater)
- reboot
- wireless failed to work (stalled on "Determining IP information for wlan0..."
during boot)

Solved by:
- downloading appropriate 2.6.23.14-115 kernel from:
http://koji.fedoraproject.org/koji/buildinfo?buildID=32352
(in my case kernel-2.6.23.14-115.fc8.x86_64.rpm)
- install with:
yum localinstall --nogpgcheck kernel-2.6.23.14-115.fc8.x86_64.rpm
- reboot

Thanks for the fix.
Comment 5 Jon Stanley 2008-01-25 20:57:28 EST
This is in updates-testing.  Manually moving the state of this bug on ON_QA
until a stable update -115 or later hits.
Comment 6 Jonah 2008-01-30 08:51:45 EST
i have the same problem. only unlike the users above i use proprietary nvidia
drivers from livna. kmod-nvidia.

so although install the .115 kernel fixes the wifi my display is messed up as
livna doesn't have a .115 kmod-driver yet.

can you please release this kernel as a proper update in fedora and then livna
etc will make drivers that will work for it.

it's pretty bad not having any wifi, i'm still having to choose the previous
kernel in grub to use nvidia...
Comment 7 Jonah 2008-01-30 08:55:40 EST
if anyone could please build and post an x86_64 kmod-nvidia.rpm that will work
in the meantime that would be awesome. thanks. also i think this bug should be
called medium at least not low. for those with laptops who can't be plugging
ethernet in and out all time wherever they go it's quite serious having no
connection...
Comment 8 Bug Zapper 2008-11-26 04:26:03 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 9 Bug Zapper 2009-01-09 02:55:47 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.