Bug 428699 - Activation keys allow systems to be registered to incorrect channels
Summary: Activation keys allow systems to be registered to incorrect channels
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration   
(Show other bugs)
Version: 510
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Pradeep Kilambi
QA Contact: Brandon Perkins
URL:
Whiteboard:
Keywords:
: 427578 444971 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-14 17:42 UTC by Justin Sherrill
Modified: 2008-09-30 14:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-24 20:09:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Justin Sherrill 2008-01-14 17:42:57 UTC
Description of problem:


Using an activation key a user can register a system to:

1.  A rhel 4 channel even though it's rhel 5 (and vice versa)
2.  A zstream channel that is earlier than the clients software (i.e. a 5.1
client can register to a 5.0 eus channel).

Essentially there is no validation before registering the system to a channel.


Version-Release number of selected component (if applicable):
5.0, 5.1

Comment 1 Pradeep Kilambi 2008-01-15 15:28:59 UTC
This is pretty old behavior, spoke to cliff and punting to 5.2

Comment 2 John Matthews 2008-01-17 23:09:42 UTC
*** Bug 427578 has been marked as a duplicate of this bug. ***

Comment 4 Clifford Perry 2008-09-24 20:09:30 UTC
Mixed between WONTFIX and NOTABUG - it is functioning as designed. The registration with activation key is registering you successfully to the exact channel you asked for within the activation key. 

I prefer this over us double checking and assuming failure. Customer may want system on that channel, due to reasons unknown to us. 

Cliff

Comment 5 Brandon Perkins 2008-09-30 14:29:32 UTC
*** Bug 444971 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.