Bug 428745 - wine binary prints stuff about pulseaudio to stdout, not stderr
wine binary prints stuff about pulseaudio to stdout, not stderr
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 16:38 EST by Ben Webb
Modified: 2008-02-10 14:14 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.54-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-01 20:20:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Webb 2008-01-14 16:38:17 EST
Description of problem:

Whenever I run a binary via wine, I get the following message on stdout:
Running padsp as pulseaudio wrapper for wine

This is annoying for me because I make a lot of use of w32 console apps, and use
their standard output. For example, I have an autoconf-like test similar to:

$ cat test.c
  int main(void) {
    printf("#define SIZEOF_INT %d\n", sizeof(int));
  }
$ cl test.c
$ ./test.exe > myheader.h

myheader.h subsequently fails to compile because the pulseaudio output ends up
there. If this output went to stderr (with all other wine output), things would
work correctly.

Version-Release number of selected component (if applicable):
wine-core-0.9.52-2.fc8

How reproducible:
Always.


Steps to Reproduce:
1. $ wine > out 2>err

Actual results:
   $ cat out
   Running padsp as pulseaudio wrapper for wine
   $ cat err
   Usage: wine PROGRAM [ARGUMENTS...]   Run the specified program
          wine --help                   Display this help and exit
          wine --version                Output version information and exit

Expected results:
All /usr/bin/wine output ends up in 'err'.
Comment 1 Andreas Bierfert 2008-01-14 16:58:22 EST
I know that this situation is not really nice but I think the reasoning for
having wine report that it is using an ugly hack to make use of pulseaudio is ok
at least for now till there is a better solution. Since this is _not_ an error
message but just a reminder I think it should go to stdout instead of stderr.
You can avoid this behavior if you e.g. call wine_bin directly. I am always open
for other suggestions so
Comment 2 Ben Webb 2008-01-14 17:27:17 EST
If I write a "Hello world" application, and run it, I expect it to print "Hello
world" and nothing else. Having it print some garbage about pulseaudio counts as
a bug to me. Running wine_bin is not an option because I run the binary
directly, i.e. via binfmt_misc, which is set up in /etc/init.d/wine to use
/usr/bin/wine, not wine_bin.

All other wine debugging stuff (for example, complaints about the timezone,
fixme:ntdll warnings, fixme:winspool warnings, etc.) goes to stderr, so does not
interfere with the program itself.
Comment 3 Davide Repetto 2008-01-24 10:37:34 EST
In bug#429420 I asked to remove the "echo" statement from /usr/bin/wine, which 
solves the problem. And YES, I too think that this is a BUG, since it breaks 
other things around wine.
Printing to stderr could be more acceptable.
Comment 4 Fedora Update System 2008-01-27 02:19:44 EST
wine-0.9.54-1.fc8, wine-docs-0.9.54-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wine wine-docs'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2008-1066
Comment 5 Laurent Rineau 2008-01-30 05:08:50 EST
Just removing the "echo" line would have suffice.

Anyway, I think that the ESound solution is the best.
Comment 6 Fedora Update System 2008-02-01 20:20:04 EST
wine-docs-0.9.54-1.fc7, wine-0.9.54-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-02-02 03:58:47 EST
wine-0.9.54-1.fc8, wine-docs-0.9.54-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Kevin Kofler 2008-02-10 14:14:02 EST
> Anyway, I think that the ESound solution is the best.

I agree. IMHO the padsp hack was a bad idea anyway. WINE should default to ESD 
for sound output, that way it will output to PulseAudio natively without 
wrapper hacks. As PulseAudio is the default sound solution in Fedora, the 
default WINE configuration should be the ESD backend.

Note You need to log in before you can comment on or make changes to this bug.