Bug 428747 - [metacity] renders transparent borders for GNOME terminal windows when compositor enabled
[metacity] renders transparent borders for GNOME terminal windows when compos...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
9
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-14 17:18 EST by Joachim Frieben
Modified: 2014-06-18 05:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-31 14:22:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Transparent windows decorations of GNOME terminal for active compositor (44.71 KB, image/png)
2008-01-14 17:18 EST, Joachim Frieben
no flags Details
Transparent window decorations of GNOME terminal for "Bright" theme. (235.34 KB, image/png)
2008-03-12 12:50 EDT, Joachim Frieben
no flags Details
Xorg.0.log for Intel Corporation 82845G/GL rev 3 (132.86 KB, text/plain)
2009-04-05 03:31 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2008-01-14 17:18:11 EST
Description of problem:
After enabling compositing effects in metacity, left, right, and lower
window borders/decorations are partially transparent but only in the
case of GNOME terminal windows.

Version-Release number of selected component (if applicable):
metacity-2.21.5-2.fc9

How reproducible:
Always.

Steps to Reproduce:
1. Enable metacity compositing effects.
  
Actual results:
GNOME terminal windows exhibit transparent decorations.

Expected results:
GNOME terminal windows exhibit opaque decorations.

Additional info:
Again, this issue only affects GNOME terminal windows. Other clients
are unaffected. Disabling the compositor restores normal appearance.
Comment 1 Joachim Frieben 2008-01-14 17:18:11 EST
Created attachment 291648 [details]
Transparent windows decorations of GNOME terminal for active compositor
Comment 2 Joachim Frieben 2008-03-12 12:38:10 EDT
I have tried with a recent Ubuntu Hardy Heron live CD, and there, the
window borders behave normally, even when the built-in compositor is
enabled. The GNOME/Metacity version in that case is 2.21.x. Further
package info for the "rawhide" system:
- xorg-x11-server-Xorg-1.4.99.901-1.20080307.fc9,
- xorg-x11-drv-ati-6.8.0-3.fc9.
Comment 3 Joachim Frieben 2008-03-12 12:50:59 EDT
Created attachment 297804 [details]
Transparent window decorations of GNOME terminal for "Bright" theme.

After some experimenting, I can now assert that the issue is related
to the window border theme controlled in "Appearance Preferences".
For most themes, the borders are opaque. Only for "Clearlooks" and
"Bright" themes, they get transparent - again: -only- for the GNOME
terminal, not other clients.
Comment 4 Bug Zapper 2008-05-14 00:46:37 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Ted Percival 2008-06-24 01:38:38 EDT
Joachim, is this still a problem? I once saw the bug on Debian, but it
disappeared long ago.
Comment 6 Joachim Frieben 2008-06-24 05:53:58 EDT
Right, issue absent from current F9 w/metacity-2.22.0-3.fc9.
Comment 7 Joachim Frieben 2008-06-30 13:42:17 EDT
Well, to be more precise: issue absent on ATI X800. On my notebook
IBM ThinkPad T23 sporting a SuperSavage IX/C chip, I still see
transparent borders. metacity bug or driver bug, that's the
question ..
Comment 8 Joachim Frieben 2008-07-09 06:32:47 EDT
Transparent borders appear on ATI X800, too, unless Option "Accelmethod"
"exa" is added to the driver section in xorg.conf.
Comment 9 Joachim Frieben 2008-07-09 06:34:21 EDT
Issue affects all versions up to metacity-2.23.34-1.fc9 rebuilt from the
"rawhide" SRPM.
Comment 10 Joachim Frieben 2008-07-23 12:28:16 EDT
On an IBM ThinkPad T23 sporting a SuperSavage IX/C chip, window borders
are even transparent regardless whether acceleration method "exa" is
enabled or not in contrast to the "radeon" driver, see comment #8.
This observation applies to a current "rawhide" system with:

- xorg-x11-server-Xorg-1.4.99.905-2.20080701.fc10
- xorg-x11-drv-savage-2.2.0-2.fc9
- metacity-2.23.55-1.fc10
Comment 11 Joachim Frieben 2008-09-30 04:48:07 EDT
The bug ist still present for current F9 w/updates and a locally built xorg-x11-server-Xorg-1.5.1-1.fc9.x86_64 unless acceleration method "exa" is chosen.
On a current current "koji" system installed on an IBM ThinkPad T23 sporting a SuperSavage IX/C chip, the issue still appears for any acceleration method.
Comment 12 Søren Sandmann Pedersen 2008-10-31 14:22:10 EDT
This needs to be fixed upstream.
Comment 13 Joachim Frieben 2009-04-05 03:24:15 EDT
(In reply to comment #12)
> This needs to be fixed upstream.  

This still an issue for a fully updated F10 on a system with an Intel 845G onboard graphics chip. Since you have closed the bug with status "UPSTREAM", please add the external bug reference, too.
Comment 14 Joachim Frieben 2009-04-05 03:31:13 EDT
Created attachment 338206 [details]
Xorg.0.log for Intel Corporation 82845G/GL rev 3

Note that acceleration architecture "xaa" is mandatory because X locks up when method "exa" is chosen instead (bug 473427).

Note You need to log in before you can comment on or make changes to this bug.