Bug 428827 - Endless loop in dependency resolution
Endless loop in dependency resolution
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 09:46 EST by Daniel Colascione
Modified: 2014-01-21 18:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-25 00:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Colascione 2008-01-15 09:46:07 EST
When I try to run yum update --obsoletes on an updates F7 distribution, pointing
it against the F8 packages by using fedora-release manually, yum enters an
endless loop in checking its dependencies. It's run for hours, spitting out the
output below.

It's yum-3.2.8-2.fc7.

Output:

--> Running transaction check
---> Package xine-lib-extras.i386 0:1.1.8-4.fc8 set to be updated
--> Processing Dependency: libdirect-1.0.so.0 for package: xine-lib-extras
--> Processing Dependency: libportaudio.so for package: lirc
--> Processing Dependency: libwnck-1.so.18 for package: bdock
--> Processing Dependency: libwnck-1.so.18 for package: heliodor
--> Processing Dependency: beryl-plugins >= 0.2.1 for package: beryl-settings
--> Processing Dependency: gstreamer-plugins-ugly = 0.10.5-2.lvn7 for package:
gstreamer-plugins-ugly-devel
--> Processing Dependency: beryl-gnome = 0.2.1-1.fc7 for package: beryl
--> Processing Dependency: beryl-kde = 0.2.1-1.fc7 for package: beryl
--> Processing Conflict: totem-xine-mozplugin conflicts totem
--> Processing Conflict: totem-xine conflicts totem
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package xine-lib-extras.i386 0:1.1.8-4.fc8 set to be updated
--> Processing Dependency: libdirect-1.0.so.0 for package: xine-lib-extras
--> Processing Dependency: libportaudio.so for package: lirc
--> Processing Dependency: libwnck-1.so.18 for package: bdock
--> Processing Dependency: libwnck-1.so.18 for package: heliodor
--> Processing Dependency: beryl-plugins >= 0.2.1 for package: beryl-settings
--> Processing Dependency: gstreamer-plugins-ugly = 0.10.5-2.lvn7 for package:
gstreamer-plugins-ugly-devel
Comment 1 Seth Vidal 2008-03-12 12:35:38 EDT
Can you test this against yum 3.2.12 in rawhide:

run:
yum install pygpgme
yum --enablerepo=development update yum

and then test it.

thanks
 
Comment 2 Brian Powell 2008-04-25 00:56:26 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note that maintenance for Fedora 7 will end 30 days after the GA of Fedora 9.

Note You need to log in before you can comment on or make changes to this bug.