Bug 428885 - pirut list index out of range after updates
pirut list index out of range after updates
Status: CLOSED DUPLICATE of bug 426975
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 16:12 EST by Bruce Ingalls
Modified: 2008-01-16 08:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-16 08:49:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Ingalls 2008-01-15 16:12:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
New install inside vmware server running on vista ultimate. Running as 32 bit on 64 bit AMD Athlon.
Selected several custom packages, which installed successfully.
Tried to launch Pirut again from menu, and it crashed with the dump below.

Version-Release number of selected component (if applicable):
pirut-1.3.28-1.fc8

How reproducible:
Always


Steps to Reproduce:
I haven't tried re-installing fc8. After a reboot, pirut still fails

1. Try a fresh install of fc8 under vmware
2. Accept the security updates from Pirut, and reboot, as directed.
3. Select all major package groups for web development
4. Select about 4 custom packages also related to web development

Actual Results:
Dump report is generated

Expected Results:
Pirut no longer starts.

Additional info:
Component: pirut
Summary: TB4c8309c5 fastestmirror.py:97:postreposetup_hook:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 483, in <module>
    main()
  File "/usr/sbin/pirut", line 479, in main
    pm.run()
  File "/usr/sbin/pirut", line 407, in run
    self.doRefresh()
  File "/usr/sbin/pirut", line 423, in doRefresh
    self.doRefreshRepos(self._onlyrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 339, in doRefreshRepos
    self.reposSetup(pbar, thisrepo)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 303, in reposSetup
    self.doTsSetup()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 72, in doTsSetup
    return self._getTs()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 85, in _getTs
    self._getTsInfo()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 91, in _getTsInfo
    self._tsInfo.setDatabases(self.rpmdb, self.pkgSack)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 529, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 384, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 214, in populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 97, in postreposetup_hook
    conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
IndexError: list index out of range

Local variables in innermost frame:
repo: InstallMedia
conduit: <yum.plugins.PostRepoSetupPluginConduit instance at 0x87ba48c>
repos: ['development', 'updates-debuginfo', 'fedora', 'development-debuginfo', 'updates-source', 'InstallMedia', 'updates-testing-debuginfo', 'updates-testing', 'updates', 'updates-testing-source', 'development-source', 'fedora-source', 'fedora-debuginfo']
repomirrors: {'InstallMedia': [], 'fedora': ['http://mirror.newnanutilities.org/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirrors.kernel.org/fedora/releases/8/Everything/i386/os', 'ftp://mirror.cs.princeton.edu/pub/mirrors/fedora/linux/releases/8/Everything/i386/os', 'http://gulus.usherbrooke.ca/pub/distro/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.anl.gov/pub/fedora/linux/releases/8/Everything/i386/os', 'http://distro.ibiblio.org/pub/linux/distributions/fedora/linux/releases/8/Everything/i386/os', 'http://ftp.linux.ncsu.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.stanford.edu/fedora/linux/releases/8/Everything/i386/os', 'ftp://thales.memphis.edu/fedora/linux/releases/8/Everything/i386/os', 'http://mirrors.reflected.net/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.steadfast.net/fedora/releases/8/Everything/i386/os', 'ftp://mirror.nyi.net/fedora/linux/releases/8/Everything/i386/os', 'ftp://mirror.colorado.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://fedora.mirror.iweb.ca/releases/8/Everything/i386/os', 'http://mirror.cc.vt.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.cogentco.com/pub/linux/fedora/linux/releases/8/Everything/i386/os', 'http://fedora.mirror.facebook.com/linux/releases/8/Everything/i386/os', 'http://kdeforge.unl.edu/mirrors/fedora/linux/releases/8/Everything/i386/os', 'http://ftp.usf.edu/pub/fedora/linux/releases/8/Everything/i386/os', 'http://srl.cs.jhu.edu/YUM/fedora/releases/8/Everything/i386/os', 'http://mirrors.tummy.com/pub/fedora.redhat.com/fedora/linux/releases/8/Everything/i386/os', 'http://limestone.uoregon.edu/ftp/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.lib.ucdavis.edu/fedora/linux/releases/8/Everything/i386/os', 'http://mirror.unl.edu/fedora/linux/releases/8/Everything/i386/os', 'ftp://ftp.applios.net/pub/fedora/linux/releases/8/Everything/i386/os', 'ftp://ftp.cse.buffalo.edu/pub/Linux/fedora/linux/releases/8/Everything/i386/os', 'ftp://ftp.software.umn.edu/linux/fedora/releases/8/Everything/i386/os', 'http://mirror.web-ster.com/fedora/releases/8/Everything/i386/os', 'ftp://ftp.uci.edu/mirrors/fedora/linux/releases/8/Everything/i386/os', 'http://mirrors.cat.pdx.edu/fedora/linux/releases/8/Everything/i386/os']}
Comment 1 Jeremy Katz 2008-01-16 08:49:53 EST

*** This bug has been marked as a duplicate of 426975 ***

Note You need to log in before you can comment on or make changes to this bug.