Bug 428897 - Package Review: open-isns
Package Review: open-isns
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: Package Review (Show other bugs)
5.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Mike Christie
:
Depends On: 182375 200554
Blocks: 188273
  Show dependency treegraph
 
Reported: 2008-01-15 16:59 EST by Scott Crenshaw
Modified: 2012-06-27 05:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-27 05:22:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob Kenna 2008-01-15 16:59:30 EST
Mike Christie is the developer ad can provide the packages
Comment 1 Mike Christie 2008-01-16 17:37:04 EST
Thanks for making this Rob.

Here is the fedora package review BZ to go with this. In that BZ are the rpms
and specs (fedora one will work on RHEL).

https://bugzilla.redhat.com/show_bug.cgi?id=429037
Comment 2 Rob Kenna 2008-01-16 17:49:13 EST
Sending Tom's way for re-assignment
Comment 3 Mike Christie 2008-01-16 17:54:43 EST
Bill/Build-guys,

I had one question that is specific to RHEL about this package.

For isns we want to be able to also do some slp querys. In Fedora, we already
have the openslp package:
http://mirrors.kernel.org/fedora/releases/8/Fedora/source/SRPMS/openslp-1.2.1-7.fc8.src.rpm

What do I need to do to get the openslp package already in Fedora, into RHEL 5
so isns can use it? Can this just be done when the isns package gets added as
part of this bugzilla, or should I open a new bz for that?
Comment 4 Bill Nottingham 2008-01-16 23:23:25 EST
No, that would need to be a new bug, new errata, new PM acks, etc. Sorry.
Comment 5 Mike Christie 2008-01-17 00:13:34 EST
(In reply to comment #4)
> No, that would need to be a new bug, new errata, new PM acks, etc. Sorry.

Ah ok thanks. I will just build isns without the slp discovery support for now then.
Comment 7 Bill Nottingham 2008-01-18 14:41:07 EST
Looking at it...

Seems reasonable from the Fedora review. Minor comments:

Version of 0.0 seems odd - upstream does have a version to go along with the
date (at least, they have 0.90, 0.91 tarballs)

Why is the name of upstream open-isns and the package isns-utils?
Comment 8 Mike Christie 2008-01-18 18:39:50 EST
(In reply to comment #7)
> Looking at it...
> 
> Seems reasonable from the Fedora review. Minor comments:
> 
> Version of 0.0 seems odd - upstream does have a version to go along with the
> date (at least, they have 0.90, 0.91 tarballs)
> 

My mistake. I fixed that for RHEL and will fix for fedora. For RHEL I wanted the
0.91 code since it does not have SLP. For Fedora I want the snapshot which has
SLP, and I will fix the naming to take into account that it is based on .91.


> Why is the name of upstream open-isns and the package isns-utils?
> 

I was just following the naming of the other scsi and iscsi packages. Instead of
TGT (name of upstream target layer prohect) we named the rpm scsi-target-utils.
For iSCSI tools/daemon the upstream project is open-iscsi/linux-iscsi, and our
package is named iscsi-initiator-utils. So I thought it would be nicer to
maintain similar naming and for the upstream open-isns package I named the rpm
isns-utils.


Here is a updated RHEL package with the version change. Let me know if you want
to name it differently too, and I will rebuild.

http://people.redhat.com/mchristi/iscsi/RHEL5/5.2/rpms/isns/v3/isns-utils-0.91-0.0.src.rpm
http://people.redhat.com/mchristi/iscsi/RHEL5/5.2/rpms/isns/v3/isns-utils.spec
Comment 9 Bill Nottingham 2008-01-19 00:20:37 EST
The name is ok, just was curious. Moving to the approved tracker.

Note You need to log in before you can comment on or make changes to this bug.