Bug 428912 - Unable to create new virtual machine with virt-manager via local media
Unable to create new virtual machine with virt-manager via local media
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-15 18:45 EST by Jim Roland
Modified: 2009-12-14 16:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-14 18:57:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log snippet from attempt to create new virtual machine via local media. (2.17 KB, text/plain)
2008-01-15 18:45 EST, Jim Roland
no flags Details

  None (edit)
Description Jim Roland 2008-01-15 18:45:12 EST
Description of problem:
unable to install via locally mounted media.  log snippet indicates it's 
looking for files to identify a valid install, however it does not find CentOS, 
Fedora, and attempts to look for RHEL media, and unable to locate autorun.  
Using RHEL 5.1 DVD media.  Have attempted using subdirs Server, VT, etc, same 
result.

How reproducible:
Always

Steps to Reproduce:
1. Normal configuration of new xen virtual machine w/virt-manager
2. Select install media from local folder (eg, mounted DVD, copied DVD to local
folder, etc)

Additional notes:
Works fine with Fedora media, but errors out on RHEL media.  According to log,
it's looking (auto-detect attempts) for CentOS, Fedora, even redhat media,
however RH media from version 5 does not work (folder structure slightly
different from others).
Comment 1 Jim Roland 2008-01-15 18:45:12 EST
Created attachment 291767 [details]
Log snippet from attempt to create new virtual machine via local media.
Comment 2 Daniel Berrange 2008-01-15 18:58:11 EST
What host OS are you using ? And what version of 'python-virtinst' RPM is it ?
Comment 3 Daniel Berrange 2008-01-15 19:22:07 EST
Actually ignore my last request - it is irrelevant. The version of
python-virtinst does not support installing off media which is mounted locally
in the host. The install media needs to be accessible to both the host and
guest, which means it has to be either:
 
 - A  http://, ftp://, nfs://  URL for paravirt
 - A  path to a ISO image, or a path to a physical CDROM device in /dev
Comment 4 Jim Roland 2008-01-16 10:22:56 EST
Host OS is RHEL5.  Have attempted with an http path and ftp path and does not
work either.
Comment 5 Jim Roland 2008-01-16 10:35:29 EST
Attempted with /dev/dvd and appears to work.  It would be most helpful if the 
documentation (in virt-manager and on RH's site (section 18) indicated more 
clear examples of possibilities for the install media field (including examples 
of using username/password in http or ftp URLs).  Standard 
http://username:password@hostname/url didn't work.
Comment 6 Cole Robinson 2008-03-10 14:38:26 EDT
Hi Jim, are you still seeing this issue? What version of python-virtinst are you
using?
Comment 7 Cole Robinson 2008-03-11 11:05:00 EDT
Looking at the log file I'm pretty sure that mounting the media failed for
whatever reason, and the error was not raised correctly. Please grab the 5.2
beta packages and try http installs, and if you are still having a problem
report it here.
Comment 8 Cole Robinson 2008-09-14 18:57:21 EDT
Since this has been in NEEDINFO for quite a while and I haven't hit a similar error, I'm closing this as WORKSFORME. If you can reproduce this on 5.2, please reopen.

Note You need to log in before you can comment on or make changes to this bug.