Bug 428918 - audacious 1.4.5-1.fc8 update leads to missing libmowgli dependency
Summary: audacious 1.4.5-1.fc8 update leads to missing libmowgli dependency
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: audacious
Version: 8
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ralf Ertzinger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-01-16 01:00 UTC by David Rees
Modified: 2008-01-17 19:43 UTC (History)
6 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-01-17 19:43:25 UTC


Attachments (Terms of Use)

Description David Rees 2008-01-16 01:00:45 UTC
It's not possible to update to the recently released audacious 1.4.5-1.fc8 as it
depends on libmowgli.so.1 which hasn't been released yet. Output from yum:

Resolving Dependencies
--> Running transaction check
---> Package audacious-plugins.x86_64 0:1.4.4-1.fc8 set to be updated
--> Processing Dependency: libmowgli.so.1()(64bit) for package: audacious-plugins
---> Package audacious-libs.x86_64 0:1.4.5-1.fc8 set to be updated
--> Processing Dependency: libmowgli.so.1()(64bit) for package: audacious-libs
---> Package audacious.x86_64 0:1.4.5-1.fc8 set to be updated
--> Processing Dependency: libmowgli.so.1()(64bit) for package: audacious
--> Finished Dependency Resolution
Error: Missing Dependency: libmowgli.so.1()(64bit) is needed by package audacious
Error: Missing Dependency: libmowgli.so.1()(64bit) is needed by package
audacious-plugins
Error: Missing Dependency: libmowgli.so.1()(64bit) is needed by package
audacious-libs

This appears to be affecting at least x86_64 and i386.

Comment 1 Ralf Ertzinger 2008-01-16 07:19:22 UTC
libmowgli has not been pushed to stable for F-8 as it should
have been. My mistake, the push has been requested.

Comment 2 Kristof Szabo 2008-01-16 08:28:55 UTC
Same problem on i686.

Comment 3 Dag 2008-01-16 09:47:01 UTC
it seems that a second library is also missing: libaudid3tag.so

Here is the output of yum:
--> Finished Dependency Resolution
Error: Missing Dependency: libmowgli.so.1 is needed by package audacious-plugins
Error: Missing Dependency: libmowgli.so.1 is needed by package audacious
Error: Missing Dependency: libaudid3tag.so is needed by package
audacious-plugins-nonfree-mp3
Error: Missing Dependency: libmowgli.so.1 is needed by package audacious-libs

thanks

Comment 4 Steve 2008-01-16 11:30:48 UTC
I've this one:

--> Running transaction check
---> Package audacious-libs.i386 0:1.4.5-1.fc8 set to be updated
--> Processing Dependency: libmowgli.so.1 for package: audacious-libs
--> Processing Dependency: libaudacious.so.5 for package: conky
--> Finished Dependency Resolution
Error: Missing Dependency: libaudacious.so.5 is needed by package conky
Error: Missing Dependency: libmowgli.so.1 is needed by package audacious-libs

Comment 5 Steve 2008-01-17 09:14:13 UTC
Seems not to be a bug. It's fixed with todays updates.

Comment 6 David Rees 2008-01-17 19:43:25 UTC
Agreed, seems to be fixed now.


Note You need to log in before you can comment on or make changes to this bug.