Bug 428951 - Transport Custom Channels between rhn satellites
Transport Custom Channels between rhn satellites
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
510
All Linux
low Severity low
: ---
: ---
Assigned To: Pradeep Kilambi
Corey Welton
: Reopened
Depends On:
Blocks: 248627
  Show dependency treegraph
 
Reported: 2008-01-16 07:38 EST by Miroslav Suchý
Modified: 2008-04-02 20:22 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 20:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2008-01-16 07:38:26 EST
Description of problem:
When software channel is created on sat1, then exported and synced in sat2. On
Sat2 it do not show in "Manage Software Channels".

Version-Release number of selected component (if applicable):
Reported by customer on 5.0.1. It happend on 5.1.0 too.

How reproducible:
deterministic

Steps to Reproduce:
1. create SW channel
2. add there some package (one is enough)
3. rhn-satellite-exporter --channel=test-channel --dir=/data/exporter
4. copy the export to sat2
5. on sat2 run satellite-sync --mount-point=/data/exporter --channel=test-channel 
6. on sat2 navigate to:
-- Channels
  -- Software Channels
the new channel is there.
7. on sat2 navigate to:
-- Channels
   -- Manage Software Channels
the new channel is NOT there.
  
Actual results:
Imported channel IS NOT in Manage Software Channels

Expected results:
Imported channel IS in Manage Software Channels

Additional info:
reported by Thomas.vonSteiger@swisscom.com on rhn-satellite-user mailing list. I
tried it and I can confirm this behaviour.
Comment 1 Jan Wildeboer 2008-01-16 08:24:25 EST
What happens if you create the channel manually before syncing? Do the packages
show up in th ecorrect channel?
Comment 2 Thomas von Steiger 2008-01-16 09:53:36 EST
The before created custom channel is only available in "Software Channels" and 
not more in "Manage Software Channels" after satellite-sync.
Maybe with the satellite-sync options --step=rpms|packages there is no change 
at the custom channel ?
Comment 3 Pradeep Kilambi 2008-01-16 11:11:20 EST
I fixed this issue as part of Bz#195293 ..closing this as a dupe..

*** This bug has been marked as a duplicate of 195293 ***
Comment 4 Pradeep Kilambi 2008-01-16 11:50:14 EST
Will let QA reverify this.. moving to QA
Comment 7 Miroslav Suchý 2008-01-22 03:30:59 EST
I tried it with child channel. Child channel channel do not throw error with
entitlements, but do not appear in 
-- Channels
   -- Manage Software Channels
Comment 8 Pradeep Kilambi 2008-01-24 13:08:12 EST
(In reply to comment #5)
Basically you need to make sure you have the same channel family on both
satellites. For custom channels that don't with no parent channel it usually
subscribes to a private-channel family.. make sure thats present on both sats..

It seems to be working fine on my sats:

Export channel:

[root@rlx-0-16 ~]# rhn-satellite-exporter --dir=/tmp/dump -csol-test02 -vvv
12:50:23 Gathering channel info...
12:50:23 Gathering binary RPM info...
12:50:23 Gathering package info...
12:50:23 Gathering errata info...
12:50:23 Gathering kickstart data...
12:50:23 Gathering kickstart files info...
[root@rlx-0-16 ~]#

[root@rlx-3-18 ~]# satellite-sync -m /tmp/dump -c sol-test02
13:02:06 Red Hat Network Satellite - file-system synchronization
13:02:06    mp:  /tmp/dump
13:02:06    db:  rhnsat/<password>@rhnsat
13:02:06 
13:02:06 Retrieving / parsing channel-families data
13:02:06 channel-families data complete
13:02:06 
13:02:06 Retrieving / parsing arches data
13:02:07 arches data complete
13:02:07 
13:02:07 Retrieving / parsing additional arches data
13:02:07 additional arches data complete
13:02:07 
13:02:07 Retrieving / parsing channel data
13:02:07    p = previously imported/synced channel
13:02:07    . = channel not yet imported/synced
13:02:07    base-channels:
13:02:07       . sol-test02                                  1
13:02:07 
13:02:07 Channel data complete
13:02:07 
13:02:07 Retrieving / parsing blacklists data
13:02:07 blacklists data complete
13:02:07 
13:02:07 Retrieving / parsing product names data
13:02:07 
13:02:07 Retrieving short package metadata (used for indexing)
13:02:07    Retrieving / parsing short package metadata: sol-test02 (1)
13:02:07 Diffing package metadata (what's missing locally?): sol-test02
            ________________________________________
Diffing:    ######################################## - complete
13:02:07 
13:02:07 Downloading rpm packages
13:02:07    Fetching any missing RPMs: sol-test02 (1)
13:02:07       1/1 Fetch successful:
patch-solaris-126868-01-1.sparc-solaris-patch.rpm (1023358 bytes)
13:02:07 Processing rpm packages complete
13:02:07 No handler for step srpms
13:02:07 
13:02:07 Downloading package metadata
13:02:07    Retrieving / parsing *relevant* package metadata: sol-test02 (1)
13:02:07    * WARNING: this may be a slow process.
            ________________________________________
Downloading:######################################## - complete
13:02:07 Environment changed, trying again...
13:02:07 
13:02:07 Retrieving / parsing channel-families data
13:02:07 channel-families data complete
13:02:07 
13:02:07 Retrieving / parsing arches data
13:02:08 arches data complete
13:02:08 
13:02:08 Retrieving / parsing additional arches data
13:02:08 additional arches data complete
13:02:08 
13:02:08 Retrieving / parsing channel data
13:02:08    p = previously imported/synced channel
13:02:08    . = channel not yet imported/synced
13:02:08    base-channels:
13:02:08       . sol-test02                                  1
13:02:08 
13:02:08 Channel data complete
13:02:08 
13:02:08 Retrieving / parsing blacklists data
13:02:08 blacklists data complete
13:02:08 
13:02:08 Retrieving / parsing product names data
13:02:08 
13:02:08 Retrieving short package metadata (used for indexing)
13:02:08    Retrieving / parsing short package metadata: sol-test02 (1)
13:02:08 Diffing package metadata (what's missing locally?): sol-test02
            ________________________________________
Diffing:    ######################################## - complete
13:02:08 
13:02:08 Downloading rpm packages
13:02:08    Fetching any missing RPMs: sol-test02 (NONE MISSING)
13:02:08 Processing rpm packages complete
13:02:08 No handler for step srpms
13:02:08 
13:02:08 Downloading package metadata
13:02:08    Retrieving / parsing *relevant* package metadata: sol-test02 (1)
13:02:08    * WARNING: this may be a slow process.
            ________________________________________
Downloading:######################################## - complete
13:02:08 Environment changed, trying again...
13:02:08 Repeated failures
    Import complete:
        Begin time: Thu Jan 24 13:02:06 2008
        End time:   Thu Jan 24 13:02:08 2008
        Elapsed:    0 hours, 0 minutes, 2 seconds


goto the ui and goto channels tab and then click all channels and you should see
the synced channel.

moving back to qa..
Comment 10 Corey Welton 2008-01-25 15:27:47 EST
QA Verified...
Comment 11 Brandon Perkins 2008-04-02 20:22:21 EDT
5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.