Bug 429014 - [RHEL5.2 kdump] ia64 systems unable to boot into kdump kernel
[RHEL5.2 kdump] ia64 systems unable to boot into kdump kernel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools (Show other bugs)
5.2
ia64 Linux
medium Severity medium
: rc
: ---
Assigned To: Neil Horman
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 14:48 EST by Jarod Wilson
Modified: 2008-05-21 11:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0313
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:23:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jarod Wilson 2008-01-16 14:48:35 EST
Description of problem:
The update from kexec-tools 1.101 + our myriad of patches to tracking the
upstream-ier kexec-tools testing tree has left ia64 systems unable to use kdump.
The crash kernel loads fine, but systems simply hang when they should be booting
into the kdump kernel.

Version-Release number of selected component (if applicable):
kexec-tools-1.102pre-8.el5

How reproducible:
Set up kdump on ia64, echo c > /proc/sysrq-trigger

Additional info:
The latest ia64 5.2 beta kernels still kdump just fine with the 5.1 kexec-tools.
Comment 1 Neil Horman 2008-01-16 16:31:52 EST
I'm currently trying an upstream tree to see if latest kerenls can boot ia64 via
kdump

Comment 2 Neil Horman 2008-01-17 15:14:21 EST
Upstream kernels seem to be doa with our kexec-tools as well.  Tring the latest
kexec-tools git tree
Comment 3 Neil Horman 2008-01-17 16:23:45 EST
note to self: replacing common kexec-elf* files in kexec subdir from 1.101 to
1.02pre fixes this.  I'll need to investigate further.
Comment 4 Neil Horman 2008-01-18 14:31:24 EST
I've noted two things today.  I can build locally and produce a working kexec
binary that successfully boots a kdump kernel if:
1) I change build_mem_notes to return -1 if any elf headers we read in are
non-null terminated
2) If I don't install the latest elfutils-devel-static on the local system

I have no idea why this works yet.
Comment 5 Neil Horman 2008-01-18 15:15:11 EST
correction, apparently the actual problem is with the %configure script for the
srpm .  If I forgo the %configure sciprt, and just use ./configure instead, the
rpm built locally works fine.
Comment 6 Neil Horman 2008-01-18 16:10:00 EST
Narrowing it down further, it appears that the default values for $RPM_OPT_FLAGS
seem to be having an adverse affect on the build for ia64.
Comment 9 Neil Horman 2008-01-21 14:21:12 EST
Fixed in kexe-tools-1.102pre-8.1, on my private pre53 branch.  I'll merge when
we open for 5.3 checkins.
Comment 11 Neil Horman 2008-01-21 14:46:27 EST
good point, I misread what version we were shipping in the initial report.
setting exception flag.
Comment 13 Jay Turner 2008-01-29 08:14:49 EST
QE ack for RHEL5.2.  This is a regression relative to 5.1 and would seriously
impact customer's ability to debug problems in addition to their ability to
provide us with debugging information.
Comment 14 RHEL Product and Program Management 2008-01-29 08:17:27 EST
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being marked as a blocker for this release.  

Please resolve ASAP.
Comment 19 errata-xmlrpc 2008-05-21 11:23:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0313.html

Note You need to log in before you can comment on or make changes to this bug.