Bug 429032 - differences between F8 install and F7-F8 DVD upgrade
differences between F8 install and F7-F8 DVD upgrade
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 16:56 EST by cje
Modified: 2008-06-10 10:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-10 10:29:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cje 2008-01-16 16:56:13 EST
Description of problem:
upgrading from up to date F7 to F8 via the DVD with all defaults accepted and
then running yum update produces a different selection of packages from a clean
F8 DVD install (with all defaults) followed by yum update.

Steps to Reproduce:
i tried it out with some VMs.  x86_64.
  
Actual results:
$ diff f8updated-16jan2008-2140 f7upgraded-16jan2008-2019
4d3
< acpid-1.0.6-4.fc8.x86_64
8d6
< alsa-plugins-pulseaudio-1.0.14-5.fc8.x86_64
19d16
< atmel-firmware-1.3-2.noarch
30a28
> autoconf-2.61-9.fc8.noarch
31a30,31
> automake-1.10-6.noarch
> avahi-0.6.17-1.fc7.i386
37,39d36
< b43-fwcutter-008-1.fc8.x86_64
< baekmuk-ttf-fonts-common-2.2-6.fc8.noarch
< baekmuk-ttf-fonts-gulim-2.2-6.fc8.noarch
43d39
< bcm43xx-fwcutter-006-3.fc8.x86_64
49a46
> bittorrent-gui-4.4.0-5.fc7.noarch
54,55d50
< bluez-utils-alsa-3.20-4.fc8.x86_64
< bluez-utils-cups-3.20-4.fc8.x86_64
73,74c68,69
< cjkunifonts-uming-0.1.20060928-4.fc8.noarch
< codeina-0.10.1-6.fc8.noarch
---
> chkfontpath-1.10.1-2.fc8.x86_64
> compiz-0.6.2-3.fc8.i386
105d99
< cyrus-sasl-plain-2.1.22-8.fc8.i386
108a103
> dbus-1.0.2-6.fc7.i386
114c109
< dbus-python-0.82.0-2.fc8.x86_64
---
> dbus-python-0.82.3-1.fc7.x86_64
115a111
> dcraw-8.80-1.fc8.x86_64
129a126
> docbook-dtds-1.0-32.fc8.noarch
146a144
> esc-1.0.1-7.fc8.x86_64
155d152
< evolution-help-2.12.2-3.fc8.x86_64
193d189
< f-spot-0.4.0-3.fc8.x86_64
224c220
< glibc-2.7-2.i686
---
> glibc-2.7-2-i686
232d227
< gnokii-0.6.18-3.fc8.x86_64
240a236
> gnome-doc-utils-0.12.0-1.fc8.noarch
257d252
< gnome-phone-manager-0.40-1.fc8.x86_64
270a266
> gnome-python2-gtksourceview-2.20.0-1.fc8.x86_64
294c290
< gpg-pubkey-4f2a6fd2-3f9d9d3b.(none)
---
> gpg-pubkey-4f2a6fd2-3f9d9d3b-(none)
310d305
< gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8.x86_64
324a320
> gtksourceview-1.8.5-3.fc8.x86_64
341d336
< hesiod-3.1.0-9.i386
355a351
> ImageMagick-6.3.5.9-1.fc8.i386
356a353,354
> imake-1.0.2-5.fc8.x86_64
> im-chooser-0.5.3-1.fc8.x86_64
372c370
< iwl4965-firmware-4.44.1.18-2.noarch
---
> jasper-libs-1.900.1-7.fc8.i386
375,376d372
< java-1.7.0-icedtea-1.7.0.0-0.19.b21.snapshot.fc8.x86_64
< java-1.7.0-icedtea-plugin-1.7.0.0-0.19.b21.snapshot.fc8.x86_64
378d373
< jomolhari-fonts-0.003-4.fc8.noarch
382d376
< kacst-fonts-1.6.2-2.fc8.noarch
393a388
> lcms-1.17-2.fc8.i386
431,432d425
< libflashsupport-000-0.1.svn20070904.i386
< libflashsupport-000-0.1.svn20070904.x86_64
433a427
> libFS-1.0.0-6.fc8.x86_64
444d437
< libglademm24-2.6.4-1.fc8.x86_64
458a452
> libgomp-4.1.2-33.i386
465a460
> libgssglue-0.1-4.fc8.i386
513d507
< libsexy-0.1.11-3.fc8.x86_64
520a515
> libsmbios-libs-0.13.13-1.fc8.i386
528a524,525
> libtermcap-2.0.8-47.i386
> libtermcap-2.0.8-47.x86_64
529a527
> libthai-0.1.7-6.fc8.i386
541a540
> libutempter-1.1.5-1.fc8.i386
547a547
> libwmf-0.2.8.4-17.fc8.i386
612a613
> linuxwacom-0.7.8.3-3.fc8.i386
614d614
< lklug-fonts-0.2.2-5.fc8.noarch
620,628d619
< lohit-fonts-bengali-2.1.5-3.fc8.noarch
< lohit-fonts-gujarati-2.1.5-3.fc8.noarch
< lohit-fonts-hindi-2.1.5-3.fc8.noarch
< lohit-fonts-kannada-2.1.5-3.fc8.noarch
< lohit-fonts-malayalam-2.1.5-3.fc8.noarch
< lohit-fonts-oriya-2.1.5-3.fc8.noarch
< lohit-fonts-punjabi-2.1.5-3.fc8.noarch
< lohit-fonts-tamil-2.1.5-3.fc8.noarch
< lohit-fonts-telugu-2.1.5-3.fc8.noarch
631a623,624
> m17n-db-1.4.0-6.fc8.noarch
> m17n-lib-1.4.0-2.fc8.x86_64
639a633
> mcstrans-0.2.7-1.fc8.x86_64
643a638
> mesa-libGLU-7.0.2-2.fc8.i386
646a642
> mgetty-1.1.33-11.fc8.x86_64
655,659d650
< mono-data-1.2.5.1-3.fc8.x86_64
< mono-data-sqlite-1.2.5.1-3.fc8.x86_64
< mono-web-1.2.5.1-3.fc8.x86_64
< mono-winforms-1.2.5.1-3.fc8.x86_64
< mpage-2.5.5-1.fc8.x86_64
693,694d683
< nspluginwrapper-0.9.91.5-16.fc8.i386
< nspluginwrapper-0.9.91.5-16.fc8.x86_64
713a703
> openjade-1.3.2-30.fc8.x86_64
725a716
> opensp-1.5.2-6.fc8.x86_64
730c721
< openssl-0.9.8b-17.fc8.i686
---
> openssl-0.9.8b-17.fc8-i686
735d725
< paktype-fonts-2.0-2.fc8.noarch
756d745
< pavucontrol-0.9.5-0.4.svn20070925.fc8.x86_64
764a754,770
> perl-Archive-Tar-1.34-1.fc8.noarch
> perl-Compress-Raw-Zlib-2.005-3.fc8.x86_64
> perl-Compress-Zlib-2.005-2.fc8.noarch
> perl-CPAN-1.76_02-32.fc8.x86_64
> perl-devel-5.8.8-32.fc8.i386
> perl-devel-5.8.8-32.fc8.x86_64
> perl-Digest-HMAC-1.01-16.noarch
> perl-Digest-SHA1-2.11-4.fc8.x86_64
> perl-ExtUtils-Embed-1.26-32.fc8.x86_64
> perl-ExtUtils-MakeMaker-6.30-32.fc8.x86_64
> perl-HTML-Parser-3.56-2.fc8.x86_64
> perl-HTML-Tagset-3.10-6.fc8.noarch
> perl-IO-Compress-Base-2.005-2.fc8.noarch
> perl-IO-Compress-Zlib-2.005-2.fc8.noarch
> perl-IO-Socket-INET6-2.51-2.fc8.1.noarch
> perl-IO-Socket-SSL-1.02-1.fc8.1.noarch
> perl-IO-Zlib-1.07-1.noarch
765a772,776
> perl-libwww-perl-5.808-3.fc8.noarch
> perl-Net-DNS-0.61-1.fc8.x86_64
> perl-Net-IP-1.25-4.fc8.noarch
> perl-Net-SSLeay-1.30-5.fc8.1.x86_64
> perl-Socket6-0.19-4.fc8.1.x86_64
766a778,780
> perl-Test-Harness-2.56-32.fc8.x86_64
> perl-Test-Simple-0.62-32.fc8.x86_64
> perl-URI-1.35-3.1.noarch
793d806
< pulseaudio-libs-0.9.7-0.17.svn20071017.fc8.i386
795,798d807
< pulseaudio-libs-glib2-0.9.7-0.17.svn20071017.fc8.x86_64
< pulseaudio-module-gconf-0.9.7-0.17.svn20071017.fc8.x86_64
< pulseaudio-module-x11-0.9.7-0.17.svn20071017.fc8.x86_64
< pulseaudio-utils-0.9.7-0.17.svn20071017.fc8.x86_64
809a819
> python-devel-2.5.1-15.fc8.x86_64
817d826
< python-sexy-0.1.9-3.fc7.x86_64
819d827
< pyxdg-0.15-5.fc8.1.noarch
821,824c829
< ql2100-firmware-1.19.38-1.fc8.1.noarch
< ql2200-firmware-2.02.08-1.fc8.1.noarch
< ql23xx-firmware-3.03.20-1.fc8.1.noarch
< ql2400-firmware-4.00.27-1.fc8.1.noarch
---
> PyXML-0.8.4-7.x86_64
830a836
> readahead-1.4.2-3.fc8.x86_64
852,853d857
< rt61pci-firmware-1.2-4.noarch
< rt73usb-firmware-1.8-4.noarch
859c863,868
< sazanami-fonts-gothic-0.20040629-4.20061016.fc8.noarch
---
> scim-1.4.7-7.fc8.x86_64
> scim-bridge-0.4.14-1.fc8.x86_64
> scim-bridge-gtk-0.4.14-1.fc8.i386
> scim-bridge-gtk-0.4.14-1.fc8.x86_64
> scim-libs-1.4.7-7.fc8.x86_64
> scim-m17n-0.2.2-2.fc8.x86_64
865d873
< sendmail-8.14.2-1.fc8.i386
874a883
> sgml-common-0.6.3-21.fc8.noarch
885a895
> spamassassin-3.2.3-2.fc8.x86_64
916a927
> tcsh-6.15-1.fc8.x86_64
917a929
> termcap-5.5-1.20060701.1.noarch
934d945
< transmission-1.00-1.fc8.x86_64
938d948
< tzdata-java-2007k-1.fc8.noarch
954a965,966
> vnc-libs-4.1.2-23.fc8.x86_64
> vnc-server-4.1.2-23.fc8.x86_64
1035a1048
> xorg-x11-fonts-75dpi-7.2-3.fc8.noarch
1036a1050
> xorg-x11-fonts-ISO8859-1-75dpi-7.2-3.fc8.noarch
1045a1060
> xorg-x11-xfs-1.0.5-1.fc8.x86_64
1058d1072
< zenity-2.20.1-2.fc8.x86_64

Expected results:
$ diff f8updated-16jan2008-2140 f7upgraded-16jan2008-2019
$

not sure what should/can be done about this.  just thought it was worth logging. 

i'm kind of hoping that clearing up these differences might be an easy way to
solve a number of more obscure problems people may be having post upgrade.

i'm working to automate these scripts to test more complex upgrade paths in the
future.

:-)
Comment 1 Andy Lindeberg 2008-06-03 13:31:10 EDT
Does the discrepancy hold true for installing/upgrading Fedora 9?
Comment 2 cje 2008-06-03 18:18:56 EDT
i'll be testing those scenarios over the next few weeks.
Comment 3 Andy Lindeberg 2008-06-05 09:58:18 EDT
All right. Please let us know if you find it in F9.
Comment 4 cje 2008-06-06 20:35:48 EDT
okay.  here's the first test: "clean F8 x86_64 DVD install followed immediately
by F9 x86_64 upgrade" vs "clean F9 x86_64 DVD install".

packages only in upgraded system:
aspell-0.60.5-3.fc7.x86_64
aspell-en-6.0-8.fc8.x86_64
autofs-5.0.2-16.x86_64
beecrypt-4.1.2-13.x86_64
comps-extras-13-1.noarch
cracklib-python-2.8.12-2.x86_64
curl-7.18.1-1.fc9.x86_64
dejavu-lgc-fonts-2.19-1.noarch
dialog-1.1-2.20070704.fc8.x86_64
ekiga-2.0.11-1.fc8.x86_64
fedorainfinity-gdm-theme-8.0.1-1.fc8.noarch
gd-2.0.35-5.fc9.x86_64
gimp-help-2-0.2.0.13.fc8.noarch
gnome-volume-manager-2.17.0-8.fc8.x86_64
gutenprint-plugin-5.0.1-5.fc8.x86_64
libflashsupport-000-0.5.svn20070904.x86_64
libsane-hpaio-2.7.7-6.fc8.x86_64
mozplugger-1.10.1-1.x86_64
mythes-en-3.0-1.fc9.noarch
opal-2.2.11-1.fc8.x86_64
openoffice.org-langpack-en-2.4.0-12.8.fc9.x86_64
openssl-0.9.8g-6.fc9.i686
pwlib-1.10.10-2.fc8.x86_64
sazanami-fonts-gothic-0.20040629-4.20061016.fc8.noarch
SDL-1.2.13-3.fc9.x86_64
system-config-firewall-1.0.8-3.fc8.noarch
system-config-language-1.2.12-1.fc8.noarch
system-config-soundcard-2.0.6-11.fc8.noarch
xorg-x11-drv-ark-0.6.0-6.fc8.x86_64
xorg-x11-drv-avivo-0.0.1-6.fc8.x86_64
xorg-x11-drv-chips-1.1.1-5.fc8.x86_64
xorg-x11-drv-s3-0.5.0-5.fc8.x86_64
xorg-x11-drv-tseng-1.1.0-7.fc8.x86_64
xorg-x11-drv-via-0.2.2-4.fc8.x86_64
xorg-x11-fonts-truetype-7.2-3.fc8.noarch
yum-updatesd-0.7-1.fc8.noarch

plus 197 i386 packages.

packages only in installed system:
abyssinica-fonts-1.0-2.fc8.noarch
dasher-4.7.3-1.fc9.x86_64
dejavu-fonts-2.24-3.fc9.noarch
dejavu-fonts-experimental-2.24-3.fc9.noarch
djvulibre-libs-3.5.20-2.fc9.x86_64
efibootmgr-0.5.4-4.fc9.x86_64
evince-djvu-2.22.1.1-1.fc9.x86_64
evince-dvi-2.22.1.1-1.fc9.x86_64
gpg-pubkey-4f2a6fd2-3f9d9d3b.(none)
gvfs-fuse-0.2.3-11.fc9.x86_64
hunspell-1.2.1-6.fc9.i386
kerneloops-0.10-11.fc9.x86_64
libertas-usb8388-firmware-5.110.20.p49-1.fc9.noarch
libgcc-4.3.0-8.i386
libstdc++-4.3.0-8.i386
ncurses-libs-5.6-16.20080301.fc9.i386
smartmontools-config-5.38-2.fc9.x86_64
thaifonts-scalable-0.4.9-3.fc9.noarch
totem-nautilus-2.23.2-2.fc9.x86_64
VLGothic-fonts-20071215-2.fc9.noarch
yum-utils-1.1.13-2.fc9.noarch
Comment 5 Chris Lumens 2008-06-10 10:29:38 EDT
I think a lot of this can be explained by the comps.xml file.  If you're not
familiar with it, this file describes what packages make up which groups and
sets default selections.  So from F8 to F9, the comps file got new packages
added to it, some packages that were optional became default, and some that were
default became optional.  You could tell this by diffing the file between
releases, though that's going to be difficult to follow because it also includes
translations of group names and descriptions.

Now, when you upgrade, anaconda does not take the new comps file into account. 
It just upgrades the packages you've got installed, but does take into account
new deps and obsoletes.  However, your fresh F9 install will use the new comps
file so it will get these new default packages installed that F8 didn't have. 
Make sense?

The i386 packages can be explained as more multilib fun.

While this is weird and a little confusing, I don't think it's actually a bug.

Note You need to log in before you can comment on or make changes to this bug.