Bug 429115 - dhclient segfaults when reading leases file
dhclient segfaults when reading leases file
Status: CLOSED DUPLICATE of bug 428785
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 09:08 EST by Jim Meyering
Modified: 2016-04-27 01:04 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 14:10:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
since read returns ssize_t, use a temporary of that type (619 bytes, patch)
2008-01-17 09:08 EST, Jim Meyering
no flags Details | Diff

  None (edit)
Description Jim Meyering 2008-01-17 09:08:06 EST
Description of problem: with an existing leases file, dhclient always segfaults


Version-Release number of selected component (if applicable):dhclient-4.0.0-3.fc9


How reproducible: run "ifup eth0", which runs
e.g., dhclient -1 -q -lf /var/lib/dhclient/dhclient-eth0.leases -pf
/var/run/dhclient-eth0.pid eth0


Steps to Reproduce:
1.
2.
3.
  
Actual results:
Program received signal SIGSEGV, Segmentation fault.
0x000000000041b832 in get_char (cfile=0x68ce40) at conflex.c:185
185                     c = cfile->inbuf [cfile->bufix];


Expected results:
"ifup eth0" would succeed

Additional info: work-around: remove the leases file,
or apply the attached patch.
Comment 1 Jim Meyering 2008-01-17 09:08:06 EST
Created attachment 291997 [details]
since read returns ssize_t, use a temporary of that type
Comment 2 David Cantrell 2008-01-17 14:10:37 EST

*** This bug has been marked as a duplicate of 428785 ***

Note You need to log in before you can comment on or make changes to this bug.