Bug 429119 - KDE system tray doesn't show Qt system tray apps
KDE system tray doesn't show Qt system tray apps
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 09:28 EST by Mark Summerfield
Modified: 2008-01-17 12:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 12:14:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
shows the message box plus a portion of the screen that belies it (12.62 KB, image/png)
2008-01-17 11:08 EST, Mark Summerfield
no flags Details

  None (edit)
Description Mark Summerfield 2008-01-17 09:28:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.10) Gecko/20071213 Fedora/2.0.0.10-3.fc8 Firefox/2.0.0.10

Description of problem:
(1) If you build Qt 4.3.3 and compile and run the examples/desktop/systray application it says it cannot detect the system tray.
(2) I've also built a system tray app of my own and that doesn't work either.

My app worked fine with Fedora Core 6/KDE 3.5.2.

I wrote to Trolltech but they can run both fine on KDE 3.5.8, so I don't know if it is a Fedora or a KDE bug, so I thought I'd start with you guys.

Version-Release number of selected component (if applicable):
kdebase-3.5.8-9.fc8

How reproducible:
Always


Steps to Reproduce:
1. Build Qt 4.3.3. (I built from the tarball, guess you could just install the package)
2. Build and run examples/desktop/systray
3. If you get a Message box pop up saying the system tray isn't detected you're done

Actual Results:
Got the system tray isn't detected message box

Expected Results:
the app should have appeared in the system tray; no message box should have appeared

Additional info:
Comment 1 Kevin Kofler 2008-01-17 10:43:59 EST
Maybe this is related to the opposite problem we're having on F9 (KDE 3 apps 
and KDE 4 systray, where they show up in some weird window somewhere on the 
screen instead of using the Plasma systray)?
Comment 2 Rex Dieter 2008-01-17 10:52:02 EST
worksforme on my rawhide box.

To test yourself (anywhere), install qt4-doc and execute
`rpm --eval %{_qt4_examples}`/desktop/systray/systray
Comment 3 Kevin Kofler 2008-01-17 10:57:47 EST
Works for me too:
kdebase-3.5.8-9.fc8
qt4-4.3.3-1.fc8
Comment 4 Mark Summerfield 2008-01-17 11:07:28 EST
I did what Rex said (on Fedora 8, KDE spin):

Installed: qt4-doc.i386 0:4.3.3-1.fc8
Dependency Installed: qt4.i386 0:4.3.3-1.fc8 qt4-x11.i386 0:4.3.3-1.fc8
Complete!
[root@marmaduke mark]# exit
exit
: `rpm --eval %{_qt4_examples}`/desktop/systray/systray

and I just got the message box again (see the ironic attachment).
Comment 5 Mark Summerfield 2008-01-17 11:08:28 EST
Created attachment 292018 [details]
shows the message box plus a portion of the screen that belies it
Comment 6 Rex Dieter 2008-01-17 11:13:54 EST
If we can't reproduce the problem, it's going to be hard to fix.

Is this a one user on one box?  I ask, because if you could reproduce this as
another user (preferably on a different install), then we'd have something. 
Else, it's more likely something specifically wrong with *this* user on *this* box.
Comment 7 Rex Dieter 2008-01-17 11:14:27 EST
For example, have you added anything custom to your environment, ie, to
.bash_login, .bashrc?
Comment 8 Mark Summerfield 2008-01-17 12:02:26 EST
I ran the live CD, installed qt4-doc & tried again. Everything worked fine.
So I went back to my own system. I had kept all my old settings, but it seems
that kickerrc is different in KDE 3.5.2 and 3.5.8---I used the live CD's version
and then everything worked fine.

So my bug. Sorry!
Comment 9 Kevin Kofler 2008-01-17 12:14:10 EST
Let's close this then.

Note You need to log in before you can comment on or make changes to this bug.