Bug 429206 - Cannot edit line length of PDF documents
Cannot edit line length of PDF documents
Product: Fedora
Classification: Fedora
Component: pdfedit (Show other bugs)
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bernard Johnson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-01-17 17:14 EST by Keith Roberts
Modified: 2008-05-18 20:06 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-05-18 20:06:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Keith Roberts 2008-01-17 17:14:09 EST
Description of problem:

I get an error message when I try to set the line length of a PDF document.

Version-Release number of selected component (if applicable):

How reproducible:

All the time. I even downloaded and compiled pdfedit 0.3.2 myself. Still get 
the same error with setting line length of PDF document.

Steps to Reproduce:
1. Load up a PDF document into pdfedit.
2. Try to change the line length.
Actual results:

I get this error message:

PDFedit 0.3.2
> setLineWidth()
! In script '/usr/local/pdfedit-0.3.2/share/pdfedit/pdfoperator.qs',
line 15:
! TypeError. 'changeableIterator' undefined or not a function

Expected results:

I expect to be able to set the line length for a PDF document.
Comment 1 Bernard Johnson 2008-01-19 00:54:00 EST
Are we talking about line length or line width?  You use both above.
Comment 2 Keith Roberts 2008-01-28 18:13:51 EST
I'm talking about the length of a line of text. I was using the wrong feature.
Apparently setLineWidth() alters the thickness of a graphics drawing line.

Here is an example of what I'm trying to do to the line length of a PDF
document. This is globally for all text in a PDF document. Do PDF files have EOL
markers? I guess so.

With an ascii text document in a text editor, if the line wrap length is 80
characters, then any lines that are longer than that will have a CR added to the
end of the line, to make the lines wrap at that line length boundary.

Supposing I have an ascii text document in my editor that has been written with
a line length of 80 characters.

I now decide that I want to make all lines in the document wrap at character
position 60. So I set the new line length in the text editor to wrap lines at
character 60.

Then I reformat the document in the editor, and the editor reformats the ascii
text by removing the CR characters at position 80 of each line, and then
replaces the CR characters to reformat the ascii text in the appropriate
places, so that the lines now wrap at character position 60.

So in effect the above reformating procedure has reduced the physical width of
the text document by 25%.

This is what I'm trying to do to a PDF document with PDFEdit.

That will allow me to enlarge the font sizes in a PDF viewer such as KPDF,
without loosing text off the RHS of my screen, so I can have a larger font size
without having to scroll each line of the PDF document horizontally.
Comment 3 Bernard Johnson 2008-01-31 14:35:23 EST
If there is not a specific bug you are addressing here, I'm going to close this
report.  You'd get better results for enhancements or support of current
functionality from upstream.
Comment 4 Keith Roberts 2008-01-31 17:15:05 EST
OK. That's fine with me. :)

Note You need to log in before you can comment on or make changes to this bug.