Bug 429207 - Dhcp doesn't start at boot time
Dhcp doesn't start at boot time
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 429226 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-17 17:15 EST by antonio montagnani
Modified: 2009-03-21 13:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 17:56:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
part of messages (1.65 KB, application/octet-stream)
2009-03-21 12:55 EDT, yrtimiD
no flags Details
conf (419 bytes, application/octet-stream)
2009-03-21 12:56 EDT, yrtimiD
no flags Details

  None (edit)
Description antonio montagnani 2008-01-17 17:15:20 EST
Description of problem:
Dhcp service cannot be started at boot time (and afterwards..)

Version-Release number of selected component (if applicable):
dhcp-4.0.0-4.fc9

How reproducible:
Try to start dhcp

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Failure of dhcp service start-up

Expected results:
Start of service

Additional info:
Comment 1 David Cantrell 2008-01-17 17:25:07 EST
The service is not enabled by default.  You have to write an /etc/dhcpd.conf
file in order for it to work.  Do you have that?
Comment 2 antonio montagnani 2008-01-17 17:33:37 EST
(In reply to comment #1)
> The service is not enabled by default.  You have to write an /etc/dhcpd.conf
> file in order for it to work.  Do you have that?

#
# DHCP Server Configuration file.
# see /usr/share/doc/dhcp*/dhcpd.conf.sample  
# dhcpd.conf
#
# Sample configuration file for ISC dhcpd
#

# option definitions common to all supported networks...
# option domain-name "fugue.com";
# option domain-name-servers toccata.fugue.com;

# option subnet-mask 255.255.255.0;
ddns-update-style none;
subnet 192.168.0.0 netmask 255.255.255.0 {
	range 192.168.0.201 192.168.0.250;
	option subnet-mask 255.255.255.0;
	option broadcast-address 192.168.0.255;
	option routers 192.168.0.1;
	option domain-name-servers 62.211.69.250 , 212.48.4.15;
	default-lease-time 604800;
	max-lease-time 2592000;
	}

My computer has always acted as a DHCP server and it was running fine till yesterday
Comment 3 antonio montagnani 2008-01-17 17:37:46 EST
/sbin/service dhcpd restart
Avvio di dhcpd:                                            [FALLITO]

FALLITO means FAILURE
Comment 4 David Cantrell 2008-01-17 17:56:47 EST
It's that lease file parsing bug again.  Just tested your conf file here with a
new patch and dhcpd is starting up correctly.

Building now.  This will go out as dhcp-4.0.0-5.fc9.

Thanks.
Comment 5 David Cantrell 2008-01-17 20:36:49 EST
*** Bug 429226 has been marked as a duplicate of this bug. ***
Comment 6 yrtimiD 2009-03-21 12:53:22 EDT
I have almost same problem but with dhcp-4.0.0-33.fc10.i386
dhcpd fails to start on start-up, but starts manually just fine after all interfaces are up.
Comment 7 yrtimiD 2009-03-21 12:55:52 EDT
Created attachment 336167 [details]
part of messages
Comment 8 yrtimiD 2009-03-21 12:56:31 EDT
Created attachment 336168 [details]
conf
Comment 9 yrtimiD 2009-03-21 13:09:59 EDT
My problem was because of NetworkManager and it's actually Bug #486372

Note You need to log in before you can comment on or make changes to this bug.