Bug 429293 - ImportError: libdhcp6client.so.1: cannot open shared object file: No such file or directory
ImportError: libdhcp6client.so.1: cannot open shared object file: No such fil...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libdhcp (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: David Cantrell
:
: 429296 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 10:45 EST by Milan Zazrivec
Modified: 2008-05-21 10:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0401
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:24:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Milan Zazrivec 2008-01-18 10:45:08 EST
Description of problem:
Anaconda installation of RHEL5.2-Server-20080118.nightly fails with following
error:

Running anaconda, the Red Hat Enterprise Linux Server system installer - please
wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 574, in ?
    import signal, traceback, string, isys, iutil, time
  File "/usr/lib/anaconda/isys.py", line 18, in ?
    import _isys
ImportError: libdhcp6client.so.1: cannot open shared object file: No such file
or directory
install exited abnormally [1/1]

Version-Release number of selected component (if applicable):
libdhcp6client-1.0.8-1.el5 / RHEL5.2-Server-20070118.nightly

How reproducible:
Always

Steps to Reproduce:
1. Boot into RHEL5.2-Server-20080118.nightly installer
2. Select installation site and directory
  
Actual results:


Expected results:


Additional info:
Comment 1 Chris Lumens 2008-01-18 15:07:55 EST
*** Bug 429296 has been marked as a duplicate of this bug. ***
Comment 2 David Cantrell 2008-01-18 15:11:35 EST
This is a problem with libdhcp.so, so reassigning the component.
Comment 3 David Cantrell 2008-01-18 15:13:18 EST
All that needs to happen with this package is rebuilding it to link to the new
libdhcp6client.  The soname changed from libdhcp6client.so.1 to
libdhcp6client-1.0.so.2, so libdhcp just needs to link against the new lib.
Comment 5 David Cantrell 2008-01-18 15:56:13 EST
Rebuilt, new package is libdhcp-1.20-3.el5.
Comment 6 Milan Zazrivec 2008-01-21 04:56:22 EST
For some reason objdump on libdhcp.so.1 from libdhcp-1.20-3.el5 says:

...
Dynamic Section:
  NEEDED      libnl.so.1
  NEEDED      libdhcp6client.so.1
  NEEDED      libdhcp4client.so.1
  NEEDED      libc.so.6
  SONAME      libdhcp.so.1
...

I'm not quite sure what has changed, nonetheless all anaconda installs of
RHEL5.2-Server-20080121.nightly still fail with the same error.
Comment 7 David Cantrell 2008-01-21 15:48:22 EST
My mistake.  I rebuilt libdhcp in dist-5E-qu-candidate, but didn't link it with
the new version of libdhcp6client.  I have fixed this in libdhcp-1.20-4.el5:

...
Dynamic Section:
  NEEDED      libnl.so.1
  NEEDED      libdhcp6client-1.0.so.2
  NEEDED      libdhcp4client.so.1
  NEEDED      libc.so.6
  SONAME      libdhcp.so.1
...

Thanks.
Comment 8 Milan Zazrivec 2008-01-22 14:41:56 EST
I'm not sure whether this is or is not related to this bugzilla, but
the installs of RHEL5.2-Server-20080122.nightly fail with a slightly
different traceback:

Running anaconda, the Red Hat Enterprise Linux Server system installer - please
wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 574, in ?
    import signal, traceback, string, isys, iutil, time
  File "/usr/lib/anaconda/isys.py", line 18, in ?
    import _isys
ImportError: libdhcp6client-1.0.so.2: shared object cannot be dlopen()ed
install exited abnormally [1/1] 
sending termination signals...done
sending kill signals...done
disabling swap...
unmounting filesystems...
        /mnt/runtime done
        disabling /dev/loop0
        /proc/bus/usb done
        /proc done
        /dev/pts done
        /sys done
        /tmp/ramfs done
        /selinux done
you may safely reboot your system

If this problem is not related to the previous posts, I'll be happy to
open a new bugzilla for it.
Comment 9 David Cantrell 2008-01-22 15:06:12 EST
It is a new problem and it's against dhcpv6, not libdhcp.  Please open a new
bugzilla for it.  I've already fixed it, I just need the bug so I can commit a
fix and build it in to dist-5E-qu-candidate.

Thanks.
Comment 13 errata-xmlrpc 2008-05-21 10:24:08 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0401.html

Note You need to log in before you can comment on or make changes to this bug.