Bug 429296 - pxeboot install fails: anaconda busted
pxeboot install fails: anaconda busted
Status: CLOSED DUPLICATE of bug 429293
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.2
ia64 Linux
urgent Severity urgent
: rc
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 11:03 EST by George Beshers
Modified: 2008-01-18 15:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 15:07:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description George Beshers 2008-01-18 11:03:55 EST
Description of problem:
  pxeboot fails for 01/18/2008 on altix3 (netboot)
  and altix6 (hand install from images/pxeboot).

Running anaconda, the Red Hat Enterprise Linux Server system installer - please
wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 574, in ?
    import signal, traceback, string, isys, iutil, time
  File "/usr/lib/anaconda/isys.py", line 18, in ?
    import _isys
ImportError: libdhcp6client.so.1: cannot open shared object file: No such file
or directory
install exited abnormally [1/1]
sending termination signals...done


Version-Release number of selected component (if applicable):
  This is the 1/18/08 nightly from bigpapi


How reproducible:
  Systematically


Steps to Reproduce:
1.  Netboot install on altix3
2.
3.
  
Actual results:
  Anaconda fails


Expected results:
  System boots


Additional info:
  Also fails on altix6 when I copy files from images/pxeboot.

http://bugworks.engr.sgi.com/query.cgi/975971
Comment 1 George Beshers 2008-01-18 11:37:16 EST
NFS install on 1/15/08 also fails.  Should be noted that this happens right
after I provide the machine name and directory for both 1/15 and 1/18.

Note however that the messages for 1/15 are different.

Running anaconda, the Red Hat Enterprise Linux Server system installer - please
wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 574, in ?
    import signal, traceback, string, isys, iutil, time
  File "/usr/lib/anaconda/isys.py", line 18, in ?
    import _isys
ImportError: /usr/lib/libdhcp.so.1: undefined symbol: global_scope
install exited abnormally [1/1]
sending termination signals...done
Comment 2 Chris Lumens 2008-01-18 11:41:32 EST
Your second traceback has already been filed against dhcp several times (and
fixed) so don't bother with that one.  The first I think is because libdhcp has
been rebuilt already for its errata, but we have not yet rebuilt and filed
anaconda.  We hope to rebuild today, at which point I think this bug will go away.
Comment 3 Chris Lumens 2008-01-18 15:07:54 EST

*** This bug has been marked as a duplicate of 429293 ***

Note You need to log in before you can comment on or make changes to this bug.