Bug 42930 - iso-8859-15 not supported in gnome-terminal
iso-8859-15 not supported in gnome-terminal
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-30 17:40 EDT by Rodary Jacques
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-07 14:01:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodary Jacques 2001-05-30 17:40:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [fr] (X11; U; Linux 2.4.3-smp i686)

Description of problem:
iso-8859-15 not supported in gnome-terminal. Since I installed redhat-7.1,
I can't  get the euro sign (\xa4 in ASCII). I can't figure if it is a
XFree86, a xfs, or a gnome ptoblem. I tried to correct the three of them
without success.

How reproducible:
Always

Steps to Reproduce:
1.startx (with gnome and sawfish
2.start gnome-terminal (with police
-misc-fixed-medium-r-normal-*-*-200-*-*-c-*-iso8859-15)
3.
	

Actual Results:  no way: it's iso8859-1, not iso8859-15

Expected Results:  since Redhat7.0 (or upgrades for XFree?) I got the euro
sign  with AltGr+$

Additional info:

I couldn't get it either with other xtems (or friends) before. I mean it
only worked with gnome-terminal.
Comment 1 Mike A. Harris 2001-05-31 01:53:28 EDT
What locale are you using?
Comment 2 Rodary Jacques 2001-05-31 05:47:17 EDT
My locale is fr_FR
Comment 3 Mike A. Harris 2001-06-07 13:58:17 EDT
Havoc, is this a known GNOME or GNOME-term bug?  Or do you think it
is XFree related or perhaps just a local config issue?
Comment 4 Havoc Pennington 2001-06-07 14:55:35 EDT
Go to gnome-terminal prefs, turn off "Enable multibyte support."

8-bit fixed-width encodings don't work by default in 7.1, because 
we turned on Japanese support by default instead. So you have to flip the setting.
Comment 5 Rodary Jacques 2001-06-08 12:59:26 EDT
	Thanks a lot!

Note You need to log in before you can comment on or make changes to this bug.