Bug 429340 - autofs fails if nsswitch.conf doesn't have automount entry
autofs fails if nsswitch.conf doesn't have automount entry
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: autofs (Show other bugs)
4.6
All Linux
low Severity low
: rc
: ---
Assigned To: Jeffrey Moyer
Brock Organ
:
: 435036 (view as bug list)
Depends On: 332291
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 14:55 EST by Jeffrey Moyer
Modified: 2008-07-24 15:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0702
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-24 15:51:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Moyer 2008-01-18 14:55:23 EST
+++ This bug was initially created as a clone of Bug #332291 +++

Description of problem:

If /etc/nsswitch.conf doesn't have an entry for automount
autofs fails to start.

Version-Release number of selected component (if applicable):
autofs-4.1.3-231

How reproducible:
Always.

Steps to Reproduce:
Remove the line starting with "automount:" from
/etc/nsswitch.conf and try and start autofs.
  
Actual results:
autofs fails to start.

Expected results:
autofs should use files as the source of maps if there is
no entry in the nsswitch configuration.

Now that this is tested in RHTS, the autofs4 package is failing to pass.  We
need to fix this so our test suite passes.

-- Additional comment from ikent@redhat.com on 2007-11-13 01:56 EST --
An RHTS test case for this bug has been added under autofs-tests/bugzillas,
subtest bz332291.
Comment 1 Jeffrey Moyer 2008-01-18 14:56:08 EST
This bug is keeping our regression tests from passing.
Comment 2 RHEL Product and Program Management 2008-01-18 14:56:43 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Barry Donahue 2008-02-18 15:58:01 EST
Testing covered by automated regression test.
Comment 4 Jeffrey Moyer 2008-02-27 13:03:45 EST
*** Bug 435036 has been marked as a duplicate of this bug. ***
Comment 5 Jeffrey Moyer 2008-02-27 13:12:21 EST
A fix for this issue was committed to CVS and will appear in autofs versions
4.1.3-231.8 and later.  Test packages can be found at:
  http://people.redhat.com/~jmoyer/
Comment 7 Barry Donahue 2008-06-12 10:32:55 EDT
Verified by RHTS job #23575
Comment 9 errata-xmlrpc 2008-07-24 15:51:42 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0702.html

Note You need to log in before you can comment on or make changes to this bug.