Bug 429341 - Guest OS goes to kernel panic if illegal mac address set to vif.
Guest OS goes to kernel panic if illegal mac address set to vif.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
5.1
All Linux
high Severity medium
: rc
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks: 391501 409971
  Show dependency treegraph
 
Reported: 2008-01-18 14:58 EST by Adam Stokes
Modified: 2010-10-22 17:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-12 03:14:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Stokes 2008-01-18 14:58:33 EST
Description of problem:
PV guest goes to kernel panic if irregal mac address set to vif.
 This is comes from network device release procedure is not appropriate.

Version-Release number of selected component (if applicable):
xen 3.0.3

How reproducible:
100%

Steps to Reproduce:
 set irregal mac address set to vif in config file.
 boot PV domain
 goest to Kernel panic in PV domain.
  
Actual Results:
 PV domain goes to Kernel Panic.

Expected Results:
 PV domain boot successfully


Additional info:
This issue already solved by following patch.
changeset: [NET] front: Clean up error handling. This eliminates earlier
changeset 12048: b6de59741161
http:/ /xenbits.xensource.com/xen-unstable.hg?rev/b6de59741161
Comment 1 Daniel Berrange 2008-01-18 15:04:58 EST
Putting version back to 5.1 - we haven't even release 5.2, let alone 5.3
Comment 2 RHEL Product and Program Management 2008-01-18 15:06:06 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Daniel Berrange 2008-01-23 17:10:15 EST
This is a guest kernel bug -> kernel-xen
Comment 4 RHEL Product and Program Management 2008-03-11 15:36:48 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.
Comment 5 RHEL Product and Program Management 2008-06-09 17:59:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Bill Burns 2008-07-09 15:32:43 EDT
Removing 5.3 flag as capacity makes this unlikely to be fixed.
Comment 7 Chris Lalancette 2009-01-15 04:16:51 EST
Looking at this, it looks like a version of the patch mentioned in the original bug report went into 5.3.  Can you have the customer run the test again and make sure this is fixed?

Thanks,
Chris Lalancette
Comment 9 Chris Lalancette 2009-02-12 03:14:24 EST
Great.  Thanks for the test, I'm going to close out the BZ.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.