Bug 429356 - Update request; enable --skip-stat option to speed up --update createrepo calls significantly. Very usefull for Fedora and RHEL buildsystem.
Update request; enable --skip-stat option to speed up --update createrepo cal...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: createrepo (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: Luke Macken
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-18 16:11 EST by Jesse Keating
Modified: 2016-09-19 22:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0394
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:29:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2008-01-18 16:11:55 EST
Upstream has a new option flag, --skip-stat.  When used in conjunction with
--update it will skip stat()ing the files to see if they had changed and just
assume that if the file name matches that the repodata can be reused.  This
significantly increases the performance of createrepo, particularly in the
Fedora build system.  createrepo calls drop from 40~ minutes to 4 minutes.

Very very little chance of regression since this is a new option.  It has been
tested by me and the upstream author.
Comment 2 Jesse Keating 2008-01-18 16:21:54 EST
http://devel.linux.duke.edu/gitweb/?p=createrepo.git;a=commitdiff;h=cb9dfcb56f8190ffc440c7c841c969ab31d1bd91
is the upstream commit for this.  This is against the same codebase that is
already in RHEL5(.2).
Comment 8 errata-xmlrpc 2008-05-21 13:29:33 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0394.html

Note You need to log in before you can comment on or make changes to this bug.