Bug 429394 - wine update leads to dependency missing error.
wine update leads to dependency missing error.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-19 01:26 EST by Adrin Jalali
Modified: 2008-01-19 04:21 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-19 04:09:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adrin Jalali 2008-01-19 01:26:55 EST
Description of problem:
When I try to update wine from updates-testing, this happens :
# yum --enablerepo=updates-testing --enablerepo=development
--enablerepo=freshrpms update wine
Loading "presto" plugin
Loading "fastestmirror" plugin
Loading "fedorakmod" plugin
Setting up and reading Presto delta metadata
No Presto metadata available for livna-development
No Presto metadata available for updates-testing
No Presto metadata available for livna
No Presto metadata available for fedora
No Presto metadata available for adobe-linux-i386
No Presto metadata available for development
freshrpms                 100% |=========================| 2.1 kB    00:00     
No Presto metadata available for freshrpms
No Presto metadata available for fusion
Loading mirror speeds from cached hostfile
 * livna-development: rpm.livna.org
 * updates-testing: spreader.yandex.net
 * livna: rpm.livna.org
 * fedora: linux.ntcu.net
 * adobe-linux-i386: linuxdownload.adobe.com
 * development: ftp.sfc.wide.ad.jp
 * updates: ftp.mirror.tw
 * freshrpms: ayo.ie.freshrpms.net
 * fusion: www.dfm.uninsubria.it
primary.sqlite.bz2        100% |=========================| 109 kB    00:01     
Excluding Packages in global exclude list
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package wine.i386 0:0.9.53-2.fc8 set to be updated
--> Processing Dependency: wine-esd = 0.9.53-2.fc8 for package: wine
--> Processing Dependency: wine-core = 0.9.53-2.fc8 for package: wine
--> Processing Dependency: wine-tools = 0.9.53-2.fc8 for package: wine
--> Processing Dependency: wine-ldap = 0.9.53-2.fc8 for package: wine
--> Processing Dependency: wine-jack = 0.9.53-2.fc8 for package: wine
--> Processing Dependency: wine-cms = 0.9.53-2.fc8 for package: wine
--> Processing Dependency: wine-nas = 0.9.53-2.fc8 for package: wine
--> Processing Dependency: wine-twain = 0.9.53-2.fc8 for package: wine
--> Processing Dependency: wine-capi = 0.9.53-2.fc8 for package: wine
--> Running transaction check
---> Package wine-tools.i386 0:0.9.53-2.fc8 set to be updated
---> Package wine-capi.i386 0:0.9.53-2.fc8 set to be updated
---> Package wine-cms.i386 0:0.9.53-2.fc8 set to be updated
---> Package wine-ldap.i386 0:0.9.53-2.fc8 set to be updated
--> Processing Dependency: libldap_r-2.3.so.0 for package: wine-ldap
--> Processing Dependency: liblber-2.3.so.0 for package: wine-ldap
---> Package wine-esd.i386 0:0.9.53-2.fc8 set to be updated
---> Package wine-twain.i386 0:0.9.53-2.fc8 set to be updated
---> Package wine-jack.i386 0:0.9.53-2.fc8 set to be updated
---> Package wine-nas.i386 0:0.9.53-2.fc8 set to be updated
---> Package wine-core.i386 0:0.9.53-2.fc8 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: libldap_r-2.3.so.0 is needed by package wine-ldap
Error: Missing Dependency: liblber-2.3.so.0 is needed by package wine-ldap
Comment 1 Andreas Bierfert 2008-01-19 04:09:05 EST
Well the problem is in what you enable as repos. rawhide has a new ldap version.
and since you are doing some combination of updates-testing and development yum
gets confused. If you want to use development then get rid of the f8 repos. As
you can see yum is pulling in the f8 version of wine which obviously should not
be build against the rawhide openldap. Current version on rawhide is 0.9.53-2.fc9.

My guess on the confusion would be related to the bad rawhide tree which went
out yesterday.
Comment 2 Adrin Jalali 2008-01-19 04:21:09 EST
Yeah your right, I'm trying to fix it by hand, I don't know why, but my yum
can't find packages in rawhide, even after I've installed new fedora-release,
now it seems that given links in that package for mirrors is problematic.

However, thanks for response.

Note You need to log in before you can comment on or make changes to this bug.