Bug 429446 - MS keyboard fails on HP xw4000 without reseating connection
MS keyboard fails on HP xw4000 without reseating connection
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: XFree86 (Show other bugs)
5
i386 Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-20 03:30 EST by Paul
Modified: 2008-01-21 07:42 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 07:42:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul 2008-01-20 03:30:21 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Description of problem:
Dear Sirs,

I have two xw4000's (both FC5) and two xw8000's one FC5 and one Windows XP). I recently purchased a Microsoft Natural Keyboard Elite (KU-0045 --- X06-19331) and it works all the time for the xw8000's but not the xw4000's. The only way it works on the HP xw4000's is if I reseat the keyboard connection into the HP when it is powered down. It always works after a reseat, but the next reboot produces a "0102: Keyboard Controller Error". In these conditions, the lights on the keyboard never come on during the power-up.

I tried setting the xorg.conf to use "XkbModel microsoft" as well as no XkbModel info on all HPs and got the same results.

If I use an older model Microsoft Natural Keyboard Elite (M/N E06401PS2DEL -- X04-58552), both the xw4000's and xw8000's work. The new keyboard works on an old XP and Win98se system (circa 2001). I also tried the original HP keyboard (KB-0316) and it appears to work on all the FC5 systems.

The info on the FC5 is kernal 2.6.15-1.2005_FC5smp and Red Hat nash version 5.0.32.

Any suggestions would be appreciated.

Thanks,
Paul

ps: have also submitted queries to HP and Microsoft

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Connect MS keyboard to HP xw4000 w/ FC5 and power up ... keyboard works
2. Power down and power back up, get "0102: Keyboard Controller Error"
3. Power down and disconnect then reconnect keyboard to and HP and power up ... keyboard works

Actual Results:
see steps to reproduce

Expected Results:
should recognize keyboard every time like it does on HP xw8000 and other Microsoft boxes

Additional info:
Regarding "severity", there is a workaround by using an old MS keyboard (or HP keyboard). Bugzilla might tell me that this issue is fixed in FC6/7/8 and that would be a very acceptable solution. At this point in time, its just a headache to disconnect / connect each time I use my Linux box.
Comment 1 Matěj Cepl 2008-01-21 07:42:59 EST
Fedora Core 5 is no longer supported distribution, could you please reproduce
this with the updated version of the currently supported distribution (Fedora 7,
8, or Rawhide)? If this issue turns out to still be reproducible, please reopen
with the additional information.

Thank you,

Matěj Cepl

Note You need to log in before you can comment on or make changes to this bug.