Bug 429472 - java doesn't work
java doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-20 16:11 EST by Jonathan Kamens
Modified: 2008-04-17 13:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-17 13:35:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2008-01-20 16:11:53 EST
I have:

firefox-3.0-0.beta2.8.fc9
jre-1.6.0_03-fcs
jre-1.5.0_13-fcs

I also tried with just jre-1.5.0 and just jre-1.6.0.

Firefox doesn't recognize the java plugin.

Don't know what to do to make it work.
Comment 1 Jonathan Kamens 2008-01-20 16:12:17 EST
I should mention that those jre packages are from Sun.
Comment 2 Matěj Cepl 2008-01-21 05:36:14 EST
Try to run (as root)

mozilla-plugin-config -r
mozilla-plugin-config -a

and then add to this bug output of

mozilla-plugin-config -l

Also could you give as also the output of

ls -l /usr/lib*/mozilla/plugins*/

please?
Comment 3 Jonathan Kamens 2008-01-21 11:35:21 EST
Aha.  Didn't have mozilla-plugin-config, since nspluginwrapper wasn't 
installed.  Installed it, but it still isn't working.

After mozilla-plugin-config -r and mozilla-pluging-config -a, mozilla-plugin-
config -l doesn't return everything until after I've launched firefox, after 
which it prints:

EXCLUDE_WRAP:
libtotem-*
EXCLUDE_LINK:

/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.mozplugger.so
  Original plugin: /usr/lib/mozilla/plugins/mozplugger.so
  Wrapper version string: 0.9.91.5
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.nsdejavu.so
  Original plugin: /usr/lib/mozilla/plugins/nsdejavu.so
  Wrapper version string: 0.9.91.5
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.nphelix.so
  Original plugin: /usr/lib/mozilla/plugins/nphelix.so
  Wrapper version string: 0.9.91.5
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.libflashplayer.so
  Original plugin: /usr/lib/mozilla/plugins/libflashplayer.so
  Wrapper version string: 0.9.91.5
File/Link /usr/lib/mozilla/plugins-wrapped/libjavaplugin_oji.so
File/Link /usr/lib/mozilla/plugins-wrapped/nphelix.xpt
/usr/lib/mozilla/plugins-wrapped/nswrapper_32_32.nppdf.so
  Original plugin: /usr/lib/mozilla/plugins/nppdf.so
  Wrapper version string: 0.9.91.5

Note that he libjavaplugin_oji.so line, which points 
at /usr/lib/mozilla/plugins/libjavaplugin_oji.so, is because I created by hand 
a link from /usr/lib/mozilla/plugins/libjavaplugin_oji.so 
to /usr/java/jre1.5.0_13/plugin/i386/ns7/libjavaplugin_oji.so.  Even with that 
link, java still doesn't work.  Java also doesn't work if I like to the 1.6 JRE 
plugin instead of the 1.5 JRE plugin.  There are no other java links anywhere 
in any of the /usr/lib*/mozilla/plugins* folders.

Any other suggestions for what to look at next?
Comment 4 Gerwin Krist 2008-03-31 02:45:21 EDT
I can confirm this (annoying) bug (running rawhide update from 30-03-08). 
Both with the official plugin (I want to use this) and fedora plugin I see the
problem. Here is my output:

[root@localhost ns7]# mozilla-plugin-config -r
[root@localhost ns7]# mozilla-plugin-config -a
[root@localhost ns7]# mozilla-plugin-config -l
EXCLUDE_WRAP:
libtotem*
libjavaplugin*
gecko-mediaplayer*
mplayerplug-in*
EXCLUDE_LINK:

[root@localhost ns7]# ls -l /usr/lib*/mozilla/plugins*/
/usr/lib/mozilla/plugins/:
total 640
lrwxrwxrwx 1 root root     72 2008-03-31 08:32 libjavaplugin_oji.so ->
/home/gerwin/Programmas/jre1.6.0_05/plugin/i386/ns7/libjavaplugin_oji.so
-rwxr-xr-x 1 root root   4364 2008-03-20 19:14 librhythmbox-itms-detection-plugin.so
-rwxr-xr-x 1 root root  47828 2008-02-20 20:28 libswfdecmozilla.so
-rwxr-xr-x 1 root root  72836 2008-03-19 23:45 libtotem-basic-plugin.so
-rw-r--r-- 1 root root    167 2008-03-19 23:45 libtotem-basic-plugin.xpt
-rwxr-xr-x 1 root root  98192 2008-03-19 23:45 libtotem-complex-plugin.so
-rw-r--r-- 1 root root   3227 2008-03-19 23:45 libtotem-complex-plugin.xpt
-rwxr-xr-x 1 root root  85848 2008-03-19 23:45 libtotem-cone-plugin.so
-rw-r--r-- 1 root root   1255 2008-03-19 23:45 libtotem-cone-plugin.xpt
-rwxr-xr-x 1 root root 104664 2008-03-19 23:45 libtotem-gmp-plugin.so
-rw-r--r-- 1 root root   4312 2008-03-19 23:45 libtotem-gmp-plugin.xpt
-rwxr-xr-x 1 root root  81180 2008-03-19 23:45 libtotem-mully-plugin.so
-rw-r--r-- 1 root root   1213 2008-03-19 23:45 libtotem-mully-plugin.xpt
-rwxr-xr-x 1 root root  94064 2008-03-19 23:45 libtotem-narrowspace-plugin.so
-rw-r--r-- 1 root root   2211 2008-03-19 23:45 libtotem-narrowspace-plugin.xpt

/usr/lib/mozilla/plugins-wrapped/:
total 0
lrwxrwxrwx 1 root root 37 2008-03-26 16:16 npwrapper.so ->
/usr/lib/nspluginwrapper/npwrapper.so
Comment 5 Matěj Cepl 2008-04-01 04:58:29 EDT
Are you able to reproduce this with the Fedora package of java-1.6.0-openjdk*
(i.e., remove all traces of the original Sun Java and try to reproduce)?
Comment 6 Jonathan Kamens 2008-04-01 10:46:49 EDT
Uninstalled Sun jre.  Reinstalled with --force java-1.6.0-openjdk.  Still can't 
use java inside firefox.  Have everything current from Rawhide.  Confirmed that 
java is enabled in the preferences checkbox.  What else should I be looking at?
Comment 7 Matěj Cepl 2008-04-01 18:10:16 EDT
Do you have java-1.6.0-openjdk-plugin-1.6.0.0-0.6.b08.fc9.i386 installed?
Comment 8 Jonathan Kamens 2008-04-02 08:08:02 EDT
Didn't have it before.  Have it now, and now java is working in my browser.  The
question, then, is how should this RPM have gotten installed on my system.  Or,
putting it another way, how will someone upgrading from an older Fedora release
get this plugin installed so they can use java?
Comment 9 Matěj Cepl 2008-04-02 11:02:43 EDT
Good question, but better to be answered who actually have an idea. Reassigning
to java folks.
Comment 10 Lillian Angel 2008-04-17 13:35:25 EDT
Upgrading from an older Fedora release:

sudo yum --enablerepo=development java-1.6.0-openjdk java-1.6.0-openjdk-plugin

Note You need to log in before you can comment on or make changes to this bug.