Bug 42952 - bindconf fails to run
Summary: bindconf fails to run
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: bindconf   
(Show other bugs)
Version: 1.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-30 23:00 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-01 10:57:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-05-30 23:00:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-5 i686)

Description of problem:
#root> bindconf
Traceback (innermost last):
  File "/usr/sbin/bindconf-gui", line 28, in ?
    from dnsdata import TestError
ImportError: cannot import name TestError

How reproducible:
Always

Steps to Reproduce:
1.run bindconf
2.
3.
	

Actual Results:  error output as decribed above

Expected Results:  obvious

Additional info:

/usr/bin/bindconf->/usr/sbin/consolehelper (usermode-1.42-1)
This problem has been there for many releases  of bindconf and usermode.

Comment 1 Harald Hoyer 2001-05-31 09:00:29 UTC
may you give the output of:
$ locate dnsdata.py


Comment 2 Need Real Name 2001-06-01 10:35:05 UTC
> locate dnsdata.py
/usr/lib/python1.5/site-packages/dnsdata.pyc
/usr/share/bindconf/dnsdata.py
/usr/share/bindconf/dnsdata.pyc


Comment 3 Need Real Name 2001-06-01 10:57:54 UTC
Problem solved!
The file /usr/lib/python1.5/site-packages/dnsdata.pyc was the cause. All is OK
after removing it.

Comment 4 Harald Hoyer 2001-06-01 11:32:15 UTC
Solution:
# rm -f /usr/lib/python1.5/site-packages/dnsdata.pyc



Note You need to log in before you can comment on or make changes to this bug.