Bug 429545 - 100% cpu when jabber server have issues
100% cpu when jabber server have issues
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pidgin (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 09:20 EST by Jan Hutař
Modified: 2008-03-10 17:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: pidgin-2.4.0-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-10 17:36:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2008-01-21 09:20:17 EST
Description of problem:
From time to time Pidgin freezes and eats 100% of cpu. After some time in this 
state it comes back to normal state and I can see that my Jabber server was 
disconnected. My jabber server usually has problems with stability, so I thing 
this could be caused by server crash or by network issues.


Version-Release number of selected component (if applicable):
pidgin-2.3.1-1.fc8.x86_64


How reproducible:
from time to time


Steps to Reproduce:
1. watch Pidgin with a Jabber account


Actual results:
window freezes, 100% CPU usage


Expected results:
no freeze, no big CPU usage


Additional info:
$ gdb attach 3046
...
(gdb) thread apply all bt

Thread 2 (Thread 1084229968 (LWP 3085)):
#0  0x0000003d32acbd66 in poll () from /lib64/libc.so.6
#1  0x000000371c431fee in g_source_remove () from /lib64/libglib-2.0.so.0
#2  0x000000371c4324aa in g_main_loop_run () from /lib64/libglib-2.0.so.0
#3  0x0000003f262068c3 in g_source_remove () from /usr/lib64/libnm_glib.so.0
#4  0x000000371c450724 in g_source_remove () from /lib64/libglib-2.0.so.0
#5  0x0000003d33606407 in start_thread () from /lib64/libpthread.so.0
#6  0x0000003d32ad4b0d in clone () from /lib64/libc.so.6

Thread 1 (Thread 46912498959024 (LWP 3046)):
#0  0x000000371c42f729 in g_source_remove () from /lib64/libglib-2.0.so.0
#1  0x000000371c431737 in g_main_context_prepare () from /lib64/libglib-2.0.so.0
#2  0x000000371c431e2d in g_source_remove () from /lib64/libglib-2.0.so.0
#3  0x000000371c4324aa in g_main_loop_run () from /lib64/libglib-2.0.so.0
#4  0x0000003b9679cbb6 in IA__gtk_main () at gtkmain.c:1163
#5  0x000000000047d48c in main (argc=1, argv=0x7fff28674158) at gtkmain.c:873
#0  0x000000371c42f729 in g_source_remove () from /lib64/libglib-2.0.so.0
Comment 1 Jan Hutař 2008-03-10 17:36:38 EDT
This seems not to be an issue with current version => closing

Note You need to log in before you can comment on or make changes to this bug.