Bug 429577 - change sysklogd logrotate script
change sysklogd logrotate script
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: sysklogd (Show other bugs)
5.2
All Linux
urgent Severity low
: rc
: ---
Assigned To: Peter Vrabec
Brian Brock
http://people.redhat.com/pvrabec/rpms...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-21 14:07 EST by Peter Vrabec
Modified: 2008-05-21 11:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2008-0418
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:42:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Vrabec 2008-01-21 14:07:54 EST
Description of problem:
rsyslogd will be provided by RHEL5 since 5.2 update. We need to change 
sysklogd logrotate script, so it will HUP both sysklogd and rsyslog.

How reproducible:
stop sysklogd
run rsyslog
run logrotate and see that rsyslog is not restarted

Expected results:
logrotate should restart running sysloging daemon

Additional info:
see #428643
Comment 3 Peter Vrabec 2008-01-21 14:35:53 EST
This change affects only logrotate.

$ diff -p syslog.log.old syslog.log
*** syslog.log.old      2001-07-09 06:23:33.000000000 +0200
--- syslog.log  2008-01-18 15:04:22.000000000 +0100
***************
*** 2,6 ****
--- 2,7 ----
      sharedscripts
      postrotate
        /bin/kill -HUP `cat /var/run/syslogd.pid 2> /dev/null` 2> /dev/null || 
true
+       /bin/kill -HUP `cat /var/run/rsyslogd.pid 2> /dev/null` 
2> /dev/null || true
      endscript
  }
Comment 7 errata-xmlrpc 2008-05-21 11:42:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0418.html

Note You need to log in before you can comment on or make changes to this bug.