Bug 429681 - Missing files while using revisor to recreate Fedora 8 Live CD
Missing files while using revisor to recreate Fedora 8 Live CD
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 08:03 EST by Valent Turkovic
Modified: 2008-01-24 09:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 13:11:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
revisor missing packages (108.42 KB, image/png)
2008-01-22 08:03 EST, Valent Turkovic
no flags Details
revisor missing packages #2 (94.79 KB, image/png)
2008-01-22 08:04 EST, Valent Turkovic
no flags Details
revisor options #1 (93.58 KB, image/png)
2008-01-22 08:04 EST, Valent Turkovic
no flags Details
revisor options #2 (100.08 KB, image/png)
2008-01-22 08:06 EST, Valent Turkovic
no flags Details
kickstart files used in Fedora 8 Live CD respin attempt :) (2.69 KB, application/octet-stream)
2008-01-24 09:49 EST, Valent Turkovic
no flags Details
kickstart files used in Fedora 8 Live CD respin attempt :) (3.85 KB, application/octet-stream)
2008-01-24 09:50 EST, Valent Turkovic
no flags Details

  None (edit)
Description Valent Turkovic 2008-01-22 08:03:24 EST
Description of problem:
I wanted to recreate Fedora 8 Live CD and so I started revisor, and choose to
make a DVD and CD versions of live cd.
this were the settings:
revisor configuration: /etc/revisor/revisor.conf
configuration section: f8-i386
destination directory: /srv/revisor/f8-i386
repositorioes: fedora and updates
kickstart configuration file:
/rawhide/usr/share/fedora-release/livecd-fedora-desktop.ks

advanced options (ones I checked):
use repositories configured in the kickstart file
use package manifest from kickstart data
include kickstart file on installation media
set installer to boot with kickstart by default

and when I click forward I get error messages that these files are missing:

No Package Matching:
mcelog
prctl
iprutils
yaboot
ppc64-utils
elilo
s390utils

I will include all screenshots with this bug.

I'm running Fedora 8 with latest updates.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Valent Turkovic 2008-01-22 08:03:24 EST
Created attachment 292502 [details]
revisor missing packages
Comment 2 Valent Turkovic 2008-01-22 08:04:10 EST
Created attachment 292503 [details]
revisor missing packages #2
Comment 3 Valent Turkovic 2008-01-22 08:04:48 EST
Created attachment 292504 [details]
revisor options #1
Comment 4 Valent Turkovic 2008-01-22 08:06:31 EST
Created attachment 292505 [details]
revisor options #2
Comment 5 Valent Turkovic 2008-01-22 08:07:51 EST
Am I doing something wrong?
Comment 6 Valent Turkovic 2008-01-22 08:08:59 EST
also I didnt use kickstart configuration file:
/rawhide/usr/share/fedora-release/livecd-fedora-desktop.ks

but I used:
/usr/share/fedora-release/livecd-fedora-desktop.ks
Comment 7 Jeroen van Meeuwen 2008-01-23 13:11:10 EST
Use ksflatten to flatten these kickstart files (the %includes in those kickstart
files are only readable to livecd-creator).

The missing packages are due to comps listing packages not available for your
architecture. These packages are not available in your repositories but since
the Fedora Project uses one overall comps file these errors keep occurring. That
is not a Revisor bug. In our next release (2.1.x) however, we did prevent the
warnings from popping up multiple boxes (so instead you get one warning listing
all packages).
Comment 8 Valent Turkovic 2008-01-24 09:48:04 EST
I did this:
ksflatten livecd-fedora-desktop.ks
ksflatten livecd-fedora-base-desktop.ks

but before that made a copy of ks files, and after flattening I compared them
and the are identical. So I don't see the point of ksflatten, I'm new to
respinning so please have patience with me :)
Comment 9 Valent Turkovic 2008-01-24 09:49:48 EST
Created attachment 292798 [details]
kickstart files used in Fedora 8 Live CD respin attempt :)
Comment 10 Valent Turkovic 2008-01-24 09:50:10 EST
Created attachment 292799 [details]
kickstart files used in Fedora 8 Live CD respin attempt :)

Note You need to log in before you can comment on or make changes to this bug.