Bug 429682 - SELinux is preventing the semodule from using potentially mislabeled files ()
SELinux is preventing the semodule from using potentially mislabeled files ()
Status: CLOSED DUPLICATE of bug 429678
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 08:10 EST by Valent Turkovic
Modified: 2008-01-23 16:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 16:27:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valent Turkovic 2008-01-22 08:10:38 EST
Description of problem:
Summary
    SELinux is preventing the semodule from using potentially mislabeled files
    (<Unknown>).

Detailed Description
    SELinux has denied semodule access to potentially mislabeled file(s)
    (<Unknown>).  This means that SELinux will not allow semodule to use these
    files.  It is common for users to edit files in their home directory or tmp
    directories and then move (mv) them to system directories.  The problem is
    that the files end up with the wrong file context which confined
    applications are not allowed to access.

Allowing Access
    If you want semodule to access this files, you need to relabel them using
    restorecon -v <Unknown>.  You might want to relabel the entire directory
    using restorecon -R -v <Unknown>.

Additional Information        

Source Context                system_u:system_r:semanage_t:s0
Target Context                system_u:object_r:unconfined_tmp_t:s0
Target Objects                None [ file ]
Affected RPM Packages         
Policy RPM                    selinux-policy-3.0.8-74.fc8
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Permissive
Plugin Name                   plugins.home_tmp_bad_labels
Host Name                     valent.oswireless
Platform                      Linux valent.oswireless 2.6.23.9-85.fc8 #1 SMP Fri
                              Dec 7 15:49:59 EST 2007 i686 i686
Alert Count                   1
First Seen                    Tue 22 Jan 2008 01:52:01 PM CET
Last Seen                     Tue 22 Jan 2008 01:52:01 PM CET
Local ID                      f33ba59b-1a54-45be-823f-d45a537b2b02
Line Numbers                  

Raw Audit Messages            

avc: denied { create } for comm=semodule name=seusers.final.tmp pid=30274
scontext=system_u:system_r:semanage_t:s0 tclass=file
tcontext=system_u:object_r:unconfined_tmp_t:s0



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. start fedora revisor and try to make live cd fased on F8 live cd
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Daniel Walsh 2008-01-23 16:27:47 EST

*** This bug has been marked as a duplicate of 429678 ***

Note You need to log in before you can comment on or make changes to this bug.