Bug 429737 - missing "import" causes adding repos during install to fail
missing "import" causes adding repos during install to fail
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum (Show other bugs)
5.2
All Linux
low Severity low
: rc
: ---
Assigned To: James Antill
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 15:09 EST by Peter Jones
Modified: 2008-05-21 10:22 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHBA-2008-0388
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:22:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch that adds the import (383 bytes, patch)
2008-01-22 15:09 EST, Peter Jones
no flags Details | Diff

  None (edit)
Description Peter Jones 2008-01-22 15:09:04 EST
Description of problem:

yum's yum/sqlitesack.py has:

from sqlutils import ExecuteSQL
...
        except sqlutils.sqlite.Error:

This causes a traceback because there's no sqlutils import.  Patch attached.
Comment 1 Peter Jones 2008-01-22 15:09:04 EST
Created attachment 292555 [details]
patch that adds the import
Comment 2 James Antill 2008-01-22 23:56:18 EST
 This is already fixed in the 3.2.8-5 release.
Comment 9 James Antill 2008-04-21 10:38:02 EDT
 So I think this will only trigger if you have to catch the exception ... which
means you have to get an sqlite.Error, trying to remeber the easiest way to do
that now.
Comment 10 James Antill 2008-04-23 00:38:08 EDT
 Ok, so adding some trace code to rpm/rpmio/rpmsq.c:rpmsqEnable() I see:

y Loaded plugins
r rpm takes SIGINT    = ref 1
r rpm releases SIGINT = ref 0
y <pkgSack>
y <Excluding Packages> etc.
[...]
y Setting up Upgrade Process
r rpm takes SIGINT    = ref 1
y Resolving Dependencies
[...]
y --> Finished Dependency Resolution
r rpm takes SIGINT    = ref 2
y --> Running transaction check
[...]
y Transaction Summary
r rpm releases SIGINT = ref 1
y Total size:
[...]

...and then the download happens.
Comment 11 James Antill 2008-04-23 00:38:33 EDT
 Gah, wrong BZ.
Comment 15 errata-xmlrpc 2008-05-21 10:22:03 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0388.html

Note You need to log in before you can comment on or make changes to this bug.