Bug 429820 - package require Pgtcl doesn't work
package require Pgtcl doesn't work
Status: CLOSED NEXTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: postgresql (Show other bugs)
5.1
All Linux
medium Severity medium
: rc
: ---
Assigned To: Tom Lane
qe-baseos-daemons
:
Depends On: 488296
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-23 04:04 EST by Mathieu Larchet
Modified: 2013-07-02 23:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 11:05:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mathieu Larchet 2008-01-23 04:04:49 EST
+++ This bug was initially created as a clone of Bug #228263 +++

Description of problem:
A tcl script can't load the package Pgtcl

Version-Release number of selected component (if applicable):
postgresql-tcl 8.1.8

How reproducible:
"package require Pgtcl" command in tcl script.

Steps to Reproduce:
1.$ tclsh
2.% package require Pgtcl

Actual results:
can't find package Pgtcl

Expected results:
1.5.2

Additional info:
The line:

package ifneeded Pgtcl 1.5.2 [list load [file join $dir libpgtcl1.5.2.so]]

is missing in file /usr/lib/Pgtcl/pkgIndex.tcl

-- Additional comment from mathieu.larchet@univ-nancy2.fr on 2008-01-23 03:48 EST --
postgresql-tcl package doesn't include pgtclsh any more.
Shared library is deployed in /usr/lib/Pgtcl with no symlink in /usr/lib.
A workaround would be to place a pgtcl file in /etc/ld.conf.d including
/usr/lib/Pgtcl in the library path
Comment 1 Tom Lane 2008-04-26 20:44:16 EDT
This is fixed upstream in pgtcl 1.5.3 and up, which means that it is not an issue in any supported Fedora 
branch.  In RHEL it is only an issue in base RHEL5 and RHEL4-Stack-V1.  Best response might be to update 
these branches to 1.5.3.
Comment 3 RHEL Product and Program Management 2008-06-02 16:23:12 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 RHEL Product and Program Management 2009-11-06 13:48:56 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 9 Tom Lane 2013-03-19 11:05:07 EDT
RHEL-5 has now reached production phase 2, in which only security and critical
bugs will be addressed.  I'm afraid this is neither, so it won't be fixed in
RHEL-5.  Since it is fixed in RHEL-6, I am closing this bug as NEXTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.