Bug 429837 - NM gnome applet doesn't offer to configure openvpn even though plugin is installed [NEEDINFO]
NM gnome applet doesn't offer to configure openvpn even though plugin is inst...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
8
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 443389 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-23 06:27 EST by Neal Becker
Modified: 2009-01-09 02:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:36:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
dcbw: needinfo? (ndbecker2)


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2008-01-23 06:27:09 EST
Description of problem:

Left click, select vpn connections, configure vpn.
Start wizard.
Only choice is vpnc.  No openvpn.

But I have:
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8.x86_64
NetworkManager-0.7.0-0.6.7.svn3204.fc8.x86_64
NetworkManager-openvpn-0.7.0-6.svn3169.fc8.i386
NetworkManager-0.7.0-0.6.7.svn3204.fc8.i386
NetworkManager-vpnc-0.7.0-0.6.3.svn3109.fc8.i386
NetworkManager-openvpn-0.7.0-6.svn3169.fc8.x86_64
NetworkManager-glib-0.7.0-0.6.7.svn3204.fc8.i386
NetworkManager-glib-0.7.0-0.6.7.svn3204.fc8.x86_64
NetworkManager-gnome-0.7.0-0.6.7.svn3204.fc8.x86_64

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Timo Hirt 2008-04-21 08:31:11 EDT
I can confirm this bug. Can't add a openvpn connection too.
Comment 2 Timo Hirt 2008-04-21 08:33:14 EDT
I forgot to say that i am using Fedora 9 and x86 architecture not Fedora 8 and
x86-64 which the reporter does.
Comment 3 Ryan B. Lynch 2008-05-04 12:00:40 EDT
I can confirm this bug on F9, on both x86-64 and i686, on three different
machines.  All of them were installed from the corresponding F9 Preview KDE
LiveCD, and then brought up-to-date with yum.

I also tried uninstalling and re-installing every NetworkManager* component,
with reboots in between.  Nothing corrected the problem.

I currently have these packages installed on all of the machines showing the
problem:

NetworkManager.i386 1:0.7.0-0.9.3.svn3623. installed
NetworkManager-devel.i386 1:0.7.0-0.9.3.svn3623. installed
NetworkManager-glib.i386 1:0.7.0-0.9.3.svn3623. installed
NetworkManager-glib-devel.i386 1:0.7.0-0.9.3.svn3623. installed
NetworkManager-gnome.i386 1:0.7.0-0.9.3.svn3623. installed
NetworkManager-openvpn.i386 1:0.7.0-10.svn3627.fc9 installed
NetworkManager-vpnc.i386 1:0.7.0-0.7.7.svn3627. installed
openvpn.i386 2.1-0.25.rc7.fc9 installed
openvpn-auth-ldap.i386 2.0.3-3.fc9 installed
Comment 4 Ryan B. Lynch 2008-05-04 12:13:16 EDT
Somebody just pointed me to BZ#443389, which describes the same symptoms and
proposes a fix.  I tried it, and it seems to work for me, so my issue is done. 
Neal Becker stated on Fedora Forums that the fix didn't work for him, though, so
I'm not going to close this--I'll let him handle the further resolution of it,
since he's the one still having the problem.
Comment 5 Neal Becker 2008-05-04 13:30:57 EDT
Please see:
http://forums.fedoraforum.org/showthread.php?t=187528&goto=newpost

It did work, and the problem is obvious.
Comment 6 Gerwin Krist 2008-05-04 17:40:56 EDT
*** Bug 443389 has been marked as a duplicate of this bug. ***
Comment 7 John Poelstra 2008-06-27 19:47:49 EDT
changing to ASSIGNED. Fedora does not use the RELEASE_PENDING state
Comment 8 Dan Williams 2008-10-01 09:47:16 EDT
Is this still an issue with latest F8 updates (ie svn4022 or later)?
Comment 9 Bug Zapper 2008-11-26 04:32:16 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Bug Zapper 2009-01-09 02:36:58 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.