Bug 429890 - SELinux is preventing restorecon(/sbin/setfiles) (setfiles_t) "read" to /var/lib/dhclient/dhclient.leases (dhcpc_state_t).
SELinux is preventing restorecon(/sbin/setfiles) (setfiles_t) "read" to /var/...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-23 11:51 EST by Zack Cerza
Modified: 2008-02-05 23:05 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-05 23:05:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zack Cerza 2008-01-23 11:51:10 EST
Description of problem:
Unsure if this is causing any side-effects.

Version-Release number of selected component (if applicable):
dhclient-4.0.0-5.fc9
selinux-policy-targeted-3.2.5-15.fc9

Additional info:
host=tak type=AVC msg=audit(1201049143.424:155): avc: denied { read } for
pid=2609 comm="restorecon" path="/var/lib/dhclient/dhclient.leases" dev=sda1
ino=147522 scontext=root:unconfined_r:setfiles_t:s0-s0:c0.c1023
tcontext=root:object_r:dhcpc_state_t:s0 tclass=file 

host=tak type=SYSCALL msg=audit(1201049143.424:155): arch=40000003 syscall=11
success=yes exit=0 a0=8ede3b8 a1=8edb3c8 a2=8eba1a0 a3=0 items=0 ppid=2558
pid=2609 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=tty1
comm="restorecon" exe="/sbin/setfiles"
subj=root:unconfined_r:setfiles_t:s0-s0:c0.c1023 key=(null)
Comment 1 Daniel Walsh 2008-01-23 15:41:43 EST
THis looks like a leaked file descriptor.

restorecon/setfiles is not reading /var/lib/dhclient/dhclient.leases
Comment 2 David Cantrell 2008-02-05 23:05:21 EST
I hate ISC code.  I think I've closed out all dhclient.leases file descriptors.
 dhclient was never doing this.  Fix is in dhcp-4.0.0-7.fc9.

Note You need to log in before you can comment on or make changes to this bug.