Bug 42992 - Apache UserDir setting broken.
Apache UserDir setting broken.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-31 01:42 EDT by Chuck Mead
Modified: 2007-04-18 12:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-16 03:01:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chuck Mead 2001-05-31 01:42:19 EDT
Description of Problem:
UserDir setting in apache does not appear to work in default config.

How Reproducible:


Steps to Reproduce:
1. create tjacobs user
2. create public_html directory
3. create a default index page in /home/tjacobs/public_html
4. using default config restart apache

Actual Results:

When I attempt to browse the above listed directory I get the following
error in /var/log/httpd/error_log

[Thu May 31 00:54:01 2001] [error] [client 66.26.229.191] File does not
exist: /home/httpd/tjacobs/public_html/

I do not understand why apache is trying to go to /
/home/httpd/tjacobs/public_html/. The error_log is correct... that
directory does not exist but it's trying to go there anyway and that bears
no relation to the actual config file. Something is very wrong.

Expected Results:

The browse should work.

Additional Information:

I have previously contacted Nalin about this.
Comment 1 Michael Schwendt 2001-06-14 19:13:24 EDT
Works fine here.

What URL do you use when trying to access your default index page?

What do you get for "grep apache /etc/passwd"?

What do you get for "grep DocumentRoot /etc/httpd/conf/httpd.conf"?
Comment 2 Chuck Mead 2001-06-14 19:21:30 EDT
What URL do you use when trying to access your default index page?

http://www.moongroup.com/~tjacobs/

What do you get for "grep apache /etc/passwd"?

apache:x:48:48:Apache:/var/www:/bin/false

What do you get for "grep DocumentRoot /etc/httpd/conf/httpd.conf"?

DocumentRoot "/var/www/html"

Comment 3 Michael Schwendt 2001-06-14 19:38:02 EDT
Hmmm, when I "rpm -e apache ; rm -rf /etc/httpd", and install from scratch, I
get this (obviously):

[Fri Jun 15 01:29:08 2001] [error] [client 192.168.1.4]
Directory index forbidden by rule: /home/tjacobs/public_html/

tjacob's home is /home/tjacobs, of course. Hence I go to httpd.conf and enable
UserDir directories, e.g. by uncommenting the example entry <Directory
/home/*/public_html>. Works for me.

Don't see where your /home/httpd comes from at all. It is an old DocumentRoot.
Comment 4 Chuck Mead 2001-06-16 03:01:48 EDT
this one is fixed. the problem was an incorrect path in the passwd file...
weird! So... it's okay to close this one if it's not already closed! Thanx...

I sent Nalin a direct email about this...
Comment 5 Nalin Dahyabhai 2001-07-24 16:17:43 EDT
Okay, closing this one out as worksforme.

Note You need to log in before you can comment on or make changes to this bug.