Bug 429931 - Unhandled exception in python pubsub examples
Unhandled exception in python pubsub examples
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: python-qpid (Show other bugs)
beta
All Linux
low Severity low
: ---
: ---
Assigned To: Rafael H. Schloming
Kim van der Riet
:
: 413981 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-23 15:51 EST by Ted Ross
Modified: 2014-12-01 18:14 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-02 11:05:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Ross 2008-01-23 15:51:48 EST
Description of problem:

When testing python interoperability with C++, the Python pubsub examples
intermittently report unhandled exceptions.

Version-Release number of selected component (if applicable):

Beta-2

How reproducible:

Run C++ pubsub publisher and Python pubsub subscriber on the same C++ broker.
This test was on an RT kernel.

Actual results:

[root@et-virt03 pubsub]# ./topic_subscriber.py 
Queues create - please start the topic producer
Messages queue: newsXC4OncHvTXmczzVFrIcNEQ==
Message 0
Message 1
Message 2
Message 3
Message 4
Message 0
Message 1
Message 2
Message 3
Message 4
That's all, folks!
Messages queue: weatherXC4OncHvTXmczzVFrIcNEQ==
Message 0
Message 1
Message 2
Message 3
Message 4
Message 0
Message 1
Message 2
Message 3
Message 4
That's all, folks!
Messages queue: usaXC4OncHvTXmczzVFrIcNEQ==
Message 0
Message 1
Message 2
Message 3
Message 4
Message 0
Message 1
Message 2
Message 3
Message 4
That's all, folks!
Messages queue: europeXC4OncHvTXmczzVFrIcNEQ==
Message 0
Message 1
Message 2
Message 3
Message 4
Message 0
Message 1
Message 2
Message 3
Message 4
That's all, folks!
Unhandled exception in thread started by 
Error in sys.excepthook:

Original exception was:
[root@et-virt03 pubsub]#
Comment 1 Gordon Sim 2008-01-24 11:00:16 EST
*** Bug 413981 has been marked as a duplicate of this bug. ***
Comment 2 Mike Bonnet 2008-06-19 23:51:00 EDT
python-qpid-0.2.668378-1.el5 has been pushed to the staging repo for testing

Note You need to log in before you can comment on or make changes to this bug.