Bug 429988 - xorg.conf: Disable in Section "Module"
xorg.conf: Disable in Section "Module"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 01:05 EST by Ralf Corsepius
Modified: 2008-02-21 12:49 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 12:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2008-01-24 01:05:01 EST
Description of problem:

man 5 xorg.conf documents:
<snip>
...
MODULE SECTION
...
       Disable "modulename"
...
</snip>

Trying to use
Section "Module"
        Disable "glx"
EndSection

in xorg.conf results into a parse error:
...
Parse error on line 18 of section Module in file /etc/X11/xorg.conf
        "Disable" is not a valid keyword in this section
....

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.3.0.0-39.fc8

How reproducible:
Always

Steps to Reproduce:
1. Add the "Module" section above to /etc/X11/xorg.conf
2. Try to launch x-server (I use run-level 3 and startx) 
  
Actual results:
Breakdown, x-server doesn't start.

Expected results:
Function. 

Either I am mis-interpreting the man page, there is a mis-match between docs and
implementation, or ... there is a bug somewhere.

Additional info:
I could have sworn 'Disable "..."' once had worked, but ... I could be wrong ;)
Comment 1 Ralf Corsepius 2008-01-24 03:19:21 EST
FWIW: http://www.x.org/archive/X11R6.8.0/doc/xorg.conf.5.html
Doesn't have the section I am citing above, anymore.

So, ... wild guess: Implementation vs. docs mismatch in F8 :/

Comment 2 Matěj Cepl 2008-01-24 11:47:45 EST
Auch, ajax?
Comment 3 Adam Jackson 2008-02-11 15:03:24 EST
It's not valid syntax in xserver 1.3.0, correct.  It is valid in rawhide, and
will be valid in xserver 1.5.

The manual for the X server in F8 does mention the Disable keyword, because the
man page was updated whole from upstream without much thought.  Building a fix
for that as 1.3.0.0-41.fc8.
Comment 4 Fedora Update System 2008-02-11 15:45:25 EST
xorg-x11-server-1.3.0.0-41.fc8 has been submitted as an update for Fedora 8
Comment 5 Adam Jackson 2008-02-21 12:49:28 EST
Fixed in updates.

Note You need to log in before you can comment on or make changes to this bug.