Bug 430007 - make templates user modifiable
make templates user modifiable
Status: CLOSED WONTFIX
Product: freeIPA
Classification: Community
Component: ipa-server (Show other bugs)
1.0
All Linux
high Severity high
: v2 release
: ---
Assigned To: Rob Crittenden
Chandrasekar Kannan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 01:40 EST by Chandrasekar Kannan
Modified: 2015-01-04 18:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-02-16 12:58:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chandrasekar Kannan 2008-01-24 01:40:26 EST
Ticket #77 (new defect)

Opened 3 months ago
make templates user modifiable
Reported by: 	kmacmill 	Assigned to: 	kmacmill
Priority: 	major 	Milestone: 	release-2
Component: 	ipa-server 	Version: 	
Keywords: 		Cc: 	
Description ΒΆ

        It's nice to be able to add a custom package that provide the "right" ntp.conf file for your setup. Maybe we can add instead an option to point to a different template? Anyway I guess we can have /usr/share/ipa on the client as well, would that be a problem?

    I would want to put it in /usr/share/ipa/client to avoid two packages spamming the same directory. Of course, that means that neither package owns /usr/share/ipa (which I guess is already the case). And by custom package, do you mean a separate package from freeipa-client or a rebuilt package. A separate package wouldn't work because it could overwrite the existing template and if you rebuild the package you can change the python. Any packaging experts have opinions on this? Basically - I agree with the goal, I just don't think we have time right now.

Just open a ticket for a following release so we don't forget, let's go on, now. (The solution is to probably put it in /etc/ipa/templates and mark them as configuration, so a different package can just modify it or something like that. Asking people to modify python is not something I like).

Note You need to log in before you can comment on or make changes to this bug.