Bug 430096 - distroverpkg option taking on wrong default value: fedora-release, should be redhat-release
distroverpkg option taking on wrong default value: fedora-release, should be ...
Status: CLOSED DUPLICATE of bug 123888
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-24 09:50 EST by David Mansfield
Modified: 2014-01-21 18:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 10:07:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mansfield 2008-01-24 09:50:45 EST
Description of problem:

According to the documentation, if distroverpkg is not specified, the value of
the option should be 'redhat-release'.  However, in fedora 8, the option is not
specified in yum.conf, but it is NOT taking the default of redhat-release, it's
taking the default 'fedora-release'.  This is a bug.

Please do not just update the documentation, this won't help.

If the default is different based on the platform, then how is someone supposed
to write a script agaist Red Hat, CentOS and Fedora?

The default must remain redhat-release as documented, and yum.conf needs to have
distrover=fedora-release added to it.


Version-Release number of selected component (if applicable):

yum-3.2.8-2.fc8
How reproducible:


Steps to Reproduce:
1. look in /etc/yum.conf
2. look at man yum.conf
3. look at /etc/yum.conf and man yum.conf on a CentOS and RHEL box.
  
Actual results:
The distroverpkg must be specified in yum.conf as fedora-release because it is
different from the documented default of redhat-release, which is a cross
platform/cross-os issue.

Expected results:


Additional info:
Comment 1 Seth Vidal 2008-01-24 10:07:58 EST

*** This bug has been marked as a duplicate of 123888 ***
Comment 2 David Mansfield 2008-01-24 10:49:30 EST
my bug is not the same as that one, as yum.conf no longer mentions any
distroverpkg, and therefore needs to inherit the default value specified in the
documentation, 'redhat-release'.  Note: redhat-release does NOT refer to a file,
but to a package, and there is NO redhat-release package, there is a fedora-release.

c/f centos yum.conf where distroverpkg is specified as centos-release.  

either yum.conf or the docs need to change.  would you accept a patch for either?
Comment 3 David Mansfield 2008-01-24 10:55:18 EST
nevermind.  I understand the response to 123888 and agree that response explains
the reason.  however, I still think the docs should be fixed.

would you accept a doc patch?
Comment 4 Seth Vidal 2008-01-24 11:04:43 EST
Doc fix to what? the docs say:

       distroverpkg
              The  package  used by yum to determine the "version" of the dis-
              tribution. This can be any installed package. Default  is  ‘red-
              hat-release’


that is entirely accurate.

What is it you want them to say?
Comment 5 Seth Vidal 2008-01-24 11:23:32 EST
Yes, it is identical.

Read more closely.

redhat-release is the package that yum looks for a provides for to determine
which  distrover to use in place of $releasever
fedora-release
centos-release
whitebox-release
all of these provide redhat-release.

The docs are correct. What centos wants to do in their conf file is up to them.
Comment 6 David Mansfield 2008-01-24 12:17:26 EST
I have to disagree.  Here is from the manpage:

       distroverpkg
              The  package  used by yum to determine the "version" of the dis-
              tribution. This can be any installed package. Default  is  ‘red-
              hat-release’.

It says 'this can be any installed package'.  In this case redhat-release is not
an installed package.  Could we change the man page to this to remove confusion
(I was confused enough to file this bug report):

      distroverpkg
              The name of a CAPABILITY provided by an installed package that 
              is used by yum to find the package which determines the "version"
              of the distribution.  This can be any installed package or 
              CAPABILITY.  Default is 'redhat-release'.

Or something that mentions this is a CAPABILITY and not per-se a package?  

Even butter, just a sentence at the end like:  'Note: the value may specify a
CAPABILITY provided by an installed package and not necessarily a package name.'

Comment 7 Seth Vidal 2008-01-24 12:23:16 EST
capability isn't something that has any meaning in the rpm world. Do you mean
'provides'?
Comment 8 James Antill 2008-01-24 12:29:14 EST
 I've changed the man page entry to:


       distroverpkg
              The  package  used by yum to determine the "version" of the dis-
              tribution. This can be any installed package. Default  is  ‘red-
              hat-release’.  You can see what provides this manually by using:
              "yum whatprovides redhat-release".
Comment 9 David Mansfield 2008-01-24 12:45:47 EST
cool.  I came up with CAPABILITY by doing 'man rpm', it says the thing you are
querying when you ask rpm --whatprovides is a CAPABILITY.  Hence my terminology.

The change is great, thanks.

Note You need to log in before you can comment on or make changes to this bug.