Bug 43011 - statement "emacs <file name> &" in .bash_profile results in TWO copies of emacs
statement "emacs <file name> &" in .bash_profile results in TWO copies of emacs
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: bash (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-31 03:19 EDT by Need Real Name
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-31 03:19:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-31 03:19:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (Windows NT 5.0; U)

Description of problem:
Using graphical login (runlevel 5). In that case the event described in Summary occurs. Not sure this 
is a bash problem; but this was the closest I could get

How reproducible:
Always

Steps to Reproduce:
1.Select graphical login during installation (probably id:5:initdefault: line in /etc/inittab)
2.Insert line "emacs <any existing text file name> &" at end of .bash_profile (to be more specific, let
   user be nonroot)
3.login
	

Actual Results:  Two emacs windows are open with same contents. The ps -A command also reveals two emacs
processes running

Expected Results:  In RH Linux 7.0, one emacs window was open

Additional info:

I am not sure this is related; but I have also noticed keyboard hangs during emacs operation in RH 
Linux 7.1 (keyboard does not work; mouse works). Since this bug is not reproducible, I have not 
investigated it
Comment 1 Bernhard Rosenkraenzer 2001-05-31 03:22:42 EDT
Yes, bashrc did get executed twice. This is fixed in rawhide (you need to 
update the bash and setup packages).


Note You need to log in before you can comment on or make changes to this bug.