Bug 430263 - openser-acc seems to be missing as a dependency
openser-acc seems to be missing as a dependency
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openser (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-25 11:37 EST by Bob Gustafson
Modified: 2008-02-18 22:15 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.3.0-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-18 22:14:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2008-01-25 11:37:07 EST
Description of problem:

I installed openser and a number of other openser\* that I thought I would need.
After configuring, I noticed that acc.so was missing.

I manually loaded yum install openser-acc and that seemed to do the trick.

Version-Release number of selected component (if applicable):

[root@hoho4 etc]# /usr/sbin/openser -V
version: openser 1.3.0-tls (x86_64/linux)

How reproducible:

seemed to be a problem even with the latest update from updates-testing
openser-1.3.0-4

Steps to Reproduce:
1. yum install openser (and a few other openser\*)
2. edit lightly /etc/openser/openser.cfg
3. /usr/sbin/openser
4. watch for errors
  
Actual results:

  openser complained about missing acc.so

Expected results:

  openser-acc should be in dependencies?

Additional info:
Comment 1 Jan ONDREJ 2008-01-25 13:14:18 EST
No errors for me. Just removed ALL lines containing "acc" from my default
openser.conf file and openser can be started without problems.

Can you try to disable ALL "acc" lines and try again?
Not just acc module loading, but also acc module parameters.
Comment 2 Bob Gustafson 2008-01-25 14:05:20 EST
Why would I eliminate acc ?
Comment 3 Jan ONDREJ 2008-01-25 14:25:48 EST
And why you have configured acc and not installed?

The default configuration requires acc module, but it is possible to remove this
from configuration, if you don't need it.
If you want to use it, please install openser-acc package.

Is it a problem, if default configuration requires another module not installed
by package dependencies?
Comment 4 Bob Gustafson 2008-01-26 02:30:15 EST
"Is it a problem, if default configuration requires another module not installed
by package dependencies?"

Yes, it was for me.. (default means default..)

Perhaps the best way to do it would be to collect all of the statements refering
to acc in one spot in the config file and comment them out. Precede these
statements with a comment that to use acc, you need to install openser-acc. This
way the information remains in the default config, but is rendered harmless.

Thanks for your efforts and reply.

Comment 5 Peter Lemenkov 2008-01-26 05:16:55 EST
Yes(In reply to comment #4)
> "Is it a problem, if default configuration requires another module not installed
> by package dependencies?"
> 
> Yes, it was for me.. (default means default..)
> 
> Perhaps the best way to do it would be to collect all of the statements refering
> to acc in one spot in the config file and comment them out. Precede these
> statements with a comment that to use acc, you need to install openser-acc. This
> way the information remains in the default config, but is rendered harmless.

Yes - this is the best solution.
Comment 6 Fedora Update System 2008-01-27 02:20:55 EST
openser-1.3.0-6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openser'.  You can provide feedback for this update here: http://admin.fedoraproject.org/F8/FEDORA-2008-1074
Comment 7 Bob Gustafson 2008-01-30 12:29:28 EST
Above link (http://admin.fedoraproject.org/F8/FEDORA-2008-1074 ) is dead.

-------

[root@hoho4 openser]# /etc/rc.d/init.d/openser start
Starting openser:                                          [  OK  ]
[root@hoho4 openser]# /etc/rc.d/init.d/openser stop
Stopping openser:                                          [FAILED]
[root@hoho4 openser]# ps ax | grep openser
 7774 pts/1    S+     0:00 grep openser
[root@hoho4 openser]# 

I think the failure to start (but showing [OK] ) is a different problem.

When I do /usr/sbin/openser, it seems to stay up.

-----------

However, if I have another application bound to port 5060 (Ekiga for example), I
still get:

[root@hoho4 openser]# /etc/rc.d/init.d/openser start
Starting openser:                                          [  OK  ]

However, if I run /usr/sbin/openser when I have another application bound to
port 5060, then a diagnostic is shown

 Jan 27 06:42:34 [3648] ERROR:core:udp_init: bind(5, 0x71f464, 16) on
192.168.49.41: Address already in use
Jan 27 06:42:34 [3648] DBG:xlog:destroy: destroy module...

and openser dies as expected.

----

There seems to be a couple of problems here.
Comment 8 Bob Gustafson 2008-01-30 12:45:31 EST
The good startup seems to be working ok now..

[root@hoho4 openser]# /etc/rc.d/init.d/openser start
Starting openser:                                          [  OK  ]
[root@hoho4 openser]# ps ax | grep openser
 7915 ?        S      0:00 /usr/sbin/openser
 7917 ?        S      0:00 /usr/sbin/openser
 7918 ?        S      0:00 /usr/sbin/openser
 7919 ?        S      0:00 /usr/sbin/openser
 7920 ?        S      0:00 /usr/sbin/openser
 7921 ?        S      0:00 /usr/sbin/openser
 7922 ?        S      0:00 /usr/sbin/openser
 7923 ?        S      0:00 /usr/sbin/openser
 7924 ?        S      0:00 /usr/sbin/openser
 7925 ?        S      0:00 /usr/sbin/openser
 7926 ?        S      0:00 /usr/sbin/openser
 7927 ?        S      0:00 /usr/sbin/openser
 7928 ?        S      0:00 /usr/sbin/openser
 7929 ?        S      0:00 /usr/sbin/openser
 7930 ?        S      0:00 /usr/sbin/openser
 7931 ?        S      0:00 /usr/sbin/openser
 7933 pts/1    S+     0:00 grep openser
[root@hoho4 openser]# /etc/rc.d/init.d/openser stop
Stopping openser:                                          [  OK  ]
[root@hoho4 openser]# ps ax | grep openser
 7945 pts/1    S+     0:00 grep openser
[root@hoho4 openser]# 

-----

However, the presence of the [OK] when in fact openser has not successfully
started is still a problem. May be related to the fact that openser starts up
children and then reports a status, which is then reported as [OK]


Comment 9 Jan ONDREJ 2008-01-30 13:36:28 EST
(In reply to comment #8)
> However, the presence of the [OK] when in fact openser has not successfully
> started is still a problem. May be related to the fact that openser starts up
> children and then reports a status, which is then reported as [OK]

Same opinion from me.
Please, if you need to solve this problem, please report it upstream in
openser-devel mailinglist or so.
Comment 10 Fedora Update System 2008-02-18 22:14:12 EST
openser-1.3.0-6.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-02-18 22:15:53 EST
openser-1.3.0-6.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.