Bug 430294 - need to remove unused schema files
need to remove unused schema files
Status: CLOSED CURRENTRELEASE
Product: Red Hat Directory Server
Classification: Red Hat
Component: Doc - config-command-file-reference (Show other bugs)
8.0
All Linux
low Severity low
: ---
: ---
Assigned To: Deon Ballard
Chandrasekar Kannan
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-25 15:45 EST by Rich Megginson
Modified: 2015-01-04 18:30 EST (History)
1 user (show)

See Also:
Fixed In Version: 8.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 14:26:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich Megginson 2008-01-25 15:45:03 EST
http://www.redhat.com/docs/manuals/dir-server/cli/8.0/ix01.html

Refers to schema files which are no longer included with the product.  Except
for 99user.ldif, the best list will be to just install RHDS 8.0 and list the
contents of /etc/dirsrv/schema

Looks like the list in
http://www.redhat.com/docs/manuals/dir-server/cli/8.0/Configuration_Command_File_Reference-Server_Configuration___Overview-LDIF_Configuration_Files___Location.html
is ok.
Comment 1 Deon Ballard 2008-02-04 16:31:37 EST
There was a table beneath the core LDIF table for schema files for legacy
Netscape servers. I deleted almost all of those, except for a couple that were
listed in /etc/dirsrv/schema. I removed: 50ns-legacy, 50ns-calendar,
51ns-calendar, 50ns-compass, 50ns-delegated-admin, 50ns-mcd-config, 50ns-mcd-li,
50ns-mcd-mail, 50ns-mcd-browser, 50ns-media, 50ns-mlm, 50ns-msg, 50ns-netschare,
50ns-news, 50ns-proxy, and 50ns-wcal. That's where all the index entries were
pointing.

I also added 10presence because it was listed in /etc/dirsrv/schema, but wasn't
listed in the LDIF table.

The list now is:
dse.ldif  
00core.ldif 
01common.ldif 
05rfc2247.ldif 
05rfc2927.ldif 
10presence.ldif 
10rfc2307.ldif 
20subscriber.ldif
25java-object.ldif
28pilot.ldif 
30ns-common.ldif 
50ns-admin.ldif 
50ns-certificate.ldif 
50ns-directory.ldif 
50ns-mail.ldif 
50ns-value.ldif
50ns-web.ldif 
60pam-plugin.ldif
99user.ldif 

Docbot link:
https://engineering.redhat.com/docbot/en-US/Red_Hat_Directory_Server/8.0/html/Configuration_Command_File_Reference/Configuration_Command_File_Reference-Core_Server_Configuration_Reference-Server_Configuration___Overview.html#Configuration_Command_File_Reference-Server_Configuration___Overview-LDIF_Configuration_Files___Location

I'll have it pushed to docbot sometime this week.
Comment 2 Deon Ballard 2008-02-12 14:26:57 EST
Updated docs are on redhat.com now. Closing the bug.
Comment 3 Chandrasekar Kannan 2008-08-11 19:55:04 EDT
Bug already CLOSED. setting screened+ flag

Note You need to log in before you can comment on or make changes to this bug.