Bug 430295 - Review Request: sagator-libclamav - ClamAV module for python, created for SAGATOR project
Review Request: sagator-libclamav - ClamAV module for python, created for SAG...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Lemenkov
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 427162
  Show dependency treegraph
 
Reported: 2008-01-25 15:45 EST by Jan ONDREJ
Modified: 2008-08-11 05:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-10 09:52:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2008-01-25 15:45:05 EST
Spec URL: http://www.salstar.sk/pub/fedora/SPECS/sagator-libclamav.spec
SRPM URL: http://www.salstar.sk/pub/sagator/fedora/8/SRPMS/sagator-libclamav-1.2.3-1.fc8.src.rpm
Description:
This is a ClamAV native support for python via libclamav for SAGATOR,
but may be used for any python script.
Script "example.py" is a part of this package.

Just three problems from rpmlint:
sagator-libclamav.src: W: strange-permission sagator-libclamav.spec 0600
sagator-libclamav.x86_64: W: spurious-executable-perm /usr/share/doc/sagator-libclamav-1.2.3/example.py
sagator-libclamav.x86_64: W: doc-file-dependency /usr/share/doc/sagator-libclamav-1.2.3/example.py /usr/bin/python

I think no one is a blocker.
1. Why rpm stores my spec file with permission 0600 ?
2. and 3. example.py is not required by this package. It is only an example, not required by package, but it's useful for users/developers.
Comment 1 Peter Lemenkov 2008-02-04 05:04:18 EST
I'll take it.
Comment 2 Jan ONDREJ 2008-02-21 09:13:09 EST
This package will be obsolete for sagator-1.1.0 and higher (currently this
package does not exist), so it is not requires to review this package.

This new sagator works perfectly for EPEL-5, F-7 and higher, but there is no
solution for EPEL-4 (sagator-1.1.0 + clamav usage requires python-ctypes not
provided for EPEL-4).

I am leaving this still open now, before the EPEL-4 problem will be solved, but
coexistence of sagator-1.1.0 with sagator-libclamav is not planned.
Comment 3 Jan ONDREJ 2008-07-10 09:52:04 EDT
Sagator 1.1.0 has been released. This package is now obsolete.

Note You need to log in before you can comment on or make changes to this bug.