Bug 43030 - 82801AA AC '97 Audio sound card plays wave files too fast.
82801AA AC '97 Audio sound card plays wave files too fast.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-31 05:09 EDT by Richard Cross
Modified: 2007-04-18 12:33 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-06 11:36:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Cross 2001-05-31 05:09:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
When I run sndconfig (from Gnome) on my Compaq Deskpro EXS P866, it detects
my sound card as a 82801AA AC '97 Audio.  However, the audio sample that
plays to test the card is working plays at approximately twice its normal
speed.  Also any programs that use wave output, such as XMMS also play
music at twice its normal speed.

How reproducible:
Always

Steps to Reproduce:
1.  run sndconfig
2.  choose ok when prompted
3.  listen to sample sound
	

Actual Results:  Sample sound plays twice as fast as normal.

Expected Results:  Sample sound should have played at normal speed.

Additional info:

There are issues with this sound card under Windows 2000 as well.  Compaq
have published a driver update for Windows that fixes this, but nothing for
RH Linux (see
http://www.compaq.com/support/files/desktops/us/locate/20_1193.html#0). 
The card is described by Compaq as "Compaq/ADI SoundMax Integrated Digital
Audio for Win 98 SE/2000/ME" and it's a motherboard integrated card.
Comment 1 Bill Nottingham 2001-05-31 10:59:50 EDT
This is a driver issue; you may want to try the 'ftsodell' option to the module.
Comment 2 Richard Cross 2001-06-05 04:44:47 EDT
Can you explain what you mean by the 'ftsodell' option?
Comment 3 Doug Ledford 2001-06-06 10:54:18 EDT
Actually, as of Red Hat 7.1, the ftsodell option no longer exists in the
i810_audio driver, so it's not an issue.  In order to help, I need you to do the
following commands on a console while logged in as root:

dmesg -n 8
rmmod i810_audio
insmod i810_audio
dmesg | tail -10 > output

Then, cut-and-paste the contents of the output file here for me to look at.

Comment 4 Richard Cross 2001-06-06 11:36:24 EDT
[root@mothra /root]# dmesg -n 8
[root@mothra /root]# rmmod i810_audio
[root@mothra /root]# insmod i810_audio
Using /lib/modules/2.4.2-2/kernel/drivers/sound/i810_audio.o
[root@mothra /root]# dmesg | tail -10 > output
[root@mothra /root]# more output
Intel 810 + AC97 Audio, version 0.02, 20:52:34 Apr  8 2001
PCI: Setting latency timer of device 00:1f.5 to 64
i810: Intel ICH 82801AA found at IO 0x2400 and 0x2000, IRQ 10
ac97_codec: AC97 Audio codec, id: 0x4144:0x5360 (Unknown)
i810_audio: setting clocking to 41290
Intel 810 + AC97 Audio, version 0.02, 20:52:34 Apr  8 2001
PCI: Setting latency timer of device 00:1f.5 to 64
i810: Intel ICH 82801AA found at IO 0x2400 and 0x2000, IRQ 10
ac97_codec: AC97 Audio codec, id: 0x4144:0x5360 (Unknown)
i810_audio: setting clocking to 41290
Comment 5 Doug Ledford 2001-06-06 11:58:06 EDT
> Intel 810 + AC97 Audio, version 0.02, 20:52:34 Apr  8 2001
                                ^^^^
This is the latest released version of the i810 audio driver.

> i810_audio: setting clocking to 41290

This indicates that the driver is doing what it thinks is correct in terms of
compensating for the clock setting on your card (which is determined by
performing a DMA test).  Why things would still be playing at twice their
intended speed is a mystery to me (well, not entirely, I would expect Sox or
other simplisitic players to have this problem, but only if they played a mono
sound sample since your card won't run in mono mode, it would mean that the
driver was reading two samples of the mono sample and playing one out of each
speaker at the same time, which would obviously double the rate of sound
playback, most intelligent sound playback devices, including xmms, recognize
that the card is a stereo only card and will double the mono sound streams so
that this doesn't happen, but you mentioned that it happens when playing back
music as well, so this shouldn't be the problem).  Without having access to this
device, or to specs from Compaq detailing *why* this is happening, the only
thing I can do is guess :-(  For now, I'm going to have to mark this as WONTFIX
until I can get the right hardware to do the work.

Note You need to log in before you can comment on or make changes to this bug.