Bug 430331 - binding to an IP address/NIC in Azureus throws SocketExceptions
binding to an IP address/NIC in Azureus throws SocketExceptions
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: azureus (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-26 03:18 EST by James Twyford
Modified: 2008-01-30 14:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-30 14:25:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Generated using the "Generate Debug Info" option in the Help menu to provide additional system info (197.15 KB, application/zip)
2008-01-26 03:18 EST, James Twyford
no flags Details

  None (edit)
Description James Twyford 2008-01-26 03:18:23 EST
Description of problem:
Using the "Bind to local IP address or interface" option in the "Advanced
Network Settings" section of the "Connection" preferences set causes Azureus to
throw a SocketException for each socket it tries to open while any value is set.

Version-Release number of selected component (if applicable):
azureus-3.0.3.4-3.fc8.x86_64

java version "1.7.0"
IcedTea Runtime Environment (build 1.7.0-b21)
IcedTea 64-Bit Server VM (build 1.7.0-b21, mixed mode)

How reproducible:
Every time

Steps to Reproduce:
1. Set a value in the "Bind to local IP address or interface" editbox
  
Actual results:
DEBUG::Sat Jan 26 03:02:12 EST
2008::com.aelitis.azureus.core.networkmanager.impl.tcp.TCPConnectionManager::runSelect::488:
  ConnectDisconnectManager::address exception: full=/74.186.47.151:52333,
hostname=adsl-074-186-047-151.sip.mia.bellsouth.net, port=52333,
unresolved=false,
full_sub=adsl-074-186-047-151.sip.mia.bellsouth.net/74.186.47.151,
host_address=74.186.47.151
 channel=java.nio.channels.SocketChannel[closed], socket=Socket[unconnected],
local_address=/fe80:0:0:0:21b:21ff:fe05:80b, local_port=48444,
remote_address=<null>, remote_port=0
   
TCPConnectionManager::mainLoop::170,TCPConnectionManager::access$600::45,TCPConnectionManager$4::runSupport::159,AEThread::run::69
java.net.SocketException: Invalid argument
        at sun.nio.ch.Net.connect(Native Method)
        at sun.nio.ch.SocketChannelImpl.connect(SocketChannelImpl.java:525)
        at
com.aelitis.azureus.core.networkmanager.impl.tcp.TCPConnectionManager.addNewRequest(TCPConnectionManager.java:265)
        at
com.aelitis.azureus.core.networkmanager.impl.tcp.TCPConnectionManager.runSelect(TCPConnectionManager.java:488)
        at
com.aelitis.azureus.core.networkmanager.impl.tcp.TCPConnectionManager.mainLoop(TCPConnectionManager.java:170)
        at
com.aelitis.azureus.core.networkmanager.impl.tcp.TCPConnectionManager.access$600(TCPConnectionManager.java:45)
        at
com.aelitis.azureus.core.networkmanager.impl.tcp.TCPConnectionManager$4.runSupport(TCPConnectionManager.java:159)
        at org.gudy.azureus2.core3.util.AEThread.run(AEThread.java:69)

Expected results:
Azu/the JVM happily uses my non-metered connection to download stuff.

Additional info:
The examples azu gives just below the edit box are as follows:
For example, '192.168.1.2' or 'eth0' (current: lo=0:0:0:0:0:0:0:1%
1;127.0.0.1,eth0=fe80:0:0:0:21b:21ff:fe05:80b%
2;192.168.20.116,eth1=fe80:0:0:0:21d:60ff:fea4:4690% 3;192.168.1.101)

I've tried various options of eth0/1, the IPv4 addresses and various bogus
options. The bogus options do cause Azu to do the correct thing and not let me
use that option.

Attached is the "debug.zip" generated using with the "Generate Debug Info"
option in the Help menu.
Comment 1 James Twyford 2008-01-26 03:18:23 EST
Created attachment 293040 [details]
Generated using the "Generate Debug Info" option in the Help menu to provide additional system info
Comment 2 James Twyford 2008-01-27 12:02:55 EST
Fixed summary/version
Comment 3 Lillian Angel 2008-01-30 13:40:24 EST
I am not able to reproduce this problem. it seems to fail when i enter in
invalid values. Are you sure that you are using it properly?
Comment 4 James Twyford 2008-01-30 14:25:51 EST
Bah. Old .azureus settings coming back to bite me. Wiped out the config folder
and it apparently works now.

Closing as WFM. Sorry for the PEBKAC bug report.

Note You need to log in before you can comment on or make changes to this bug.