Bug 430338 - BuildRequires texlive-latex doesn't pull in texlive-texmf-fonts necessary for package building
BuildRequires texlive-latex doesn't pull in texlive-texmf-fonts necessary for...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: texlive (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jindrich Novy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-26 07:41 EST by Alex Lancaster
Modified: 2013-07-02 19:26 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-28 16:12:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Lancaster 2008-01-26 07:41:04 EST
It appears that BuildRequires: texlive-latex isn't enough to pull in the
texlive-texmf-fonts package any more:

http://koji.fedoraproject.org/koji/getfile?taskID=374239&name=root.log

This causes build failures like this:

http://koji.fedoraproject.org/koji/getfile?taskID=374239&name=build.log

there appears to be some changes in the texlive package, because a previous
build of the same package *did* pull in the right deps:

texlive-texmf-fonts     noarch     2007-2.fc9       core               56 M

from:

http://koji.fedoraproject.org/packages/tor/0.1.2.18/2.fc9/data/logs/ppc64/root.log

I can work around this manually by specifying:

BuildRequires: texlive-texmf-fonts

which successfully builds:

http://koji.fedoraproject.org/koji/taskinfo?taskID=374363

but that doesn't seem like a sensible solution if texlive-texmf-fonts is
supposed to be installed for pdftex to work out of the box.
Comment 1 Jindrich Novy 2008-01-28 16:12:15 EST
Should be fixed in rawhide for now. Thanks!

Note You need to log in before you can comment on or make changes to this bug.