Bug 430359 - yum help text somewhat puzzling
yum help text somewhat puzzling
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-26 16:25 EST by Michal Jaegermann
Modified: 2014-01-21 18:01 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 15:30:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2008-01-26 16:25:16 EST
Description of problem:

'yum --help' produces, among other things:
.....
  -y                    answer yes for all questions
....
  --depcheck            answer yes for all questions

Looks suspiciously like a victim of a "copy-and-waste".

Also options like --skip-broken and --depcheck are not mentioned
in 'man yum'.

Version-Release number of selected component (if applicable):
yum-3.2.10-2.fc9
Comment 1 Seth Vidal 2008-03-12 12:43:30 EDT
YUMBUGDAY
Comment 2 James Antill 2008-03-12 13:22:02 EDT
 There is no --depcheck in core yum, is this from a plugin?
Comment 3 Michal Jaegermann 2008-03-12 15:30:33 EDT
> There is no --depcheck in core yum, is this from a plugin?

Possibly.  Typing 'yum --help' produces on my screeen:

# yum --help
Loaded plugins: depcheck, fastestmirror, refresh-updatesd
Usage: yum [options] COMMAND
.......
  -y                    answer yes for all questions
.....
  --skip-broken         skip packages with depsolving problems
  --depcheck            answer yes for all questions

and after 'rpm -qa "yum*"' I see these:

yum-metadata-parser-1.1.2-8.fc9.x86_64
yum-fastestmirror-1.1.11-5.fc9.noarch
yum-refresh-updatesd-1.1.11-5.fc9.noarch
yum-3.2.12-3.fc9.noarch
yum-utils-1.1.11-5.fc9.noarch
yum-updatesd-0.9-1.fc9.noarch

OTOH 'rpm -qf /usr/lib/yum-plugins/depcheck.py' tells me
"file /usr/lib/yum-plugins/depcheck.py is not owned by any package"
so this looks like a leftover from some updates which "forgot"
to remove these.  And indeed /usr/lib/yum-plugins/depcheck.py
has the following code:

        parser.add_option("", "--depcheck", dest="depcheck",
                action="store_true", default=False,
                help="answer yes for all questions")

which would explain why the above shows up.  I guess that I just
dump those files.

I the meanwhile '--skip-broken' did show up on 'man yum' so it
looks like that all of this can be now closed.

Note You need to log in before you can comment on or make changes to this bug.