Bug 430361 - revelation fails to open preference-set file if path contains space character
revelation fails to open preference-set file if path contains space character
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: revelation (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Thorsten Leemhuis
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-26 16:39 EST by Kevin R. Page
Modified: 2008-01-27 07:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-27 07:46:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin R. Page 2008-01-26 16:39:21 EST
Description of problem:
If a the open-on-start file (set in Revelation prefs) has a path containing a
space character, after asking for the password(!) Revelation fails with:

Traceback (most recent call last):
  File "/usr/bin/revelation", line 264, in <lambda>
    self.datafile.connect("changed", lambda w,f: self.__state_file(f))
  File "/usr/bin/revelation", line 481, in __state_file
    os.chdir(os.path.dirname(file))
OSError: [Errno 2] No such file or directory: '/home/user/spaced%20path'

Version-Release number of selected component (if applicable):
revelation-0.4.11-3.1
Comment 1 Thorsten Leemhuis 2008-01-27 07:46:15 EST
The problem is dealed with upstream already:
http://svn.codepoet.no/revelation/ticket/271

There is even a workaround mentioned: "To avoid this problem I run gconf-editor,
and I change "%20" with " " in the path of the file, and I don't access anymore
the Preferences dialog otherwise the problem appears again."

Once it will be fixed the fix will be incorporated in Fedora as well. 

Note You need to log in before you can comment on or make changes to this bug.