Bug 430389 - bug when openning Add/Remove Software
bug when openning Add/Remove Software
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-27 06:17 EST by BooDy
Modified: 2008-03-12 12:46 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 12:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description BooDy 2008-01-27 06:17:12 EST
Description of problem:
this bug occurs when i open Add/Remove Software and when i write a yum command
in Terminal



Version-Release number of selected component (if applicable):
CentOS-5.1



Actual results:
Component: Software Manager
Summary: TBfa533769 config.py:75:__set__:ValueError: Error parsing 'rpm --import
http://centos.karan.org/RPM-GPG-KEY-karan.org.txt': URL must be http, ftp, file
or https not ""

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 453, in ?
    main()
  File "/usr/sbin/pirut", line 446, in main
    pm = PackageManager(options.config)
  File "/usr/sbin/pirut", line 60, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 122, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 134, in
doConfigSetup
    self.getReposFromConfig()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 194, in
getReposFromConfig
    thisrepo = self.readRepoConfig(parser, section)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 216, in
readRepoConfig
    repo.populate(parser, section, self.conf)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 371, in populate
    setattr(self, name, value)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 75, in __set__
    raise ValueError('Error parsing %r: %s' % (value, str(e)))
ValueError: Error parsing 'rpm --import
http://centos.karan.org/RPM-GPG-KEY-karan.org.txt': URL must be http, ftp, file
or https not ""

Local variables in innermost frame:
obj: kbs-CentOS-Testing
self: <yum.config.UrlListOption object at 0x9dbe40c>
e: URL must be http, ftp, file or https not ""
value: rpm --import http://centos.karan.org/RPM-GPG-KEY-karan.org.txt



Additional info:
i'm still beginner in linux ... and this bug occured since i tried to install
byrel as this link says
http://www.howtoforge.com/beryl_centos5.0
Comment 1 David Lawrence 2008-01-27 12:31:28 EST
Changing to proper product/component so a developer will see this report.
Comment 2 Jeremy Katz 2008-01-28 22:46:19 EST
What versions of the yum and pirut packages do you have installed (the output of
'rpm -q yum pirut')?
Comment 3 Seth Vidal 2008-03-12 12:46:12 EDT
closing insufficient data

Note You need to log in before you can comment on or make changes to this bug.